Sign in with
Sign up | Sign in
Your question

Old ASUS Mobo freezing in POST with SATA HD

Last response: in Storage
Share
May 29, 2010 9:03:21 AM

I have an Asus A7N8X-E Delux Motherboard, with two sata ports that can be used in a raid. I recently bought a 1.5TB SATA HardDrive. During boot, it goes to a screen telling me to press Ctrl + S or F4 to setup a raid. Then displays any SATA things I have on the computer. As soon as it detects the HD, it freezes on that screen. The sata ports appear to be working fine, I've got a SATA DVD Burner that works with them. The only thing it displays is the model number of the HD when it detects it. Not the size of it or anything else. I've tried using the jumpers on the HD, to set it to 150 instead of 300, and set it for Windows XP partition, but it still freezes as soon as it detects the HD.

I've googled this problem before, and seen that other people have had it, but I haven't found any actual answer to the problem or why it's happening. I've upgraded to Service Pack 3 for windows XP, and flashed the BIOS to the last one Asus released for this Mobo. Nothing works that I can find.

Has anybody had this happen before, or know anything that could be causing it to happen? I'm at an utter loss here.
a b G Storage
May 29, 2010 9:45:29 AM

Seen this happen several times (with other controllers/MoBo's), it usualy means the BIOS is buggy and won't support 1TB or larger drives.

To be a bit more technical:
It has to do with the LBA being (internaly) stored (in the BIOS) as a signed 32-bit number rather than un-signed 64-bit (as it should be).

A BIOS update might fix it (if one is available), or maybe a secondary controller card.
m
0
l
May 29, 2010 9:49:30 AM

I've upgraded the BIOS to the last one that was put out for this motherboard. And it's still not working. How would I go about getting a secondary controller card?
m
0
l
Related resources
a b Ĉ ASUS
May 29, 2010 12:47:34 PM

Are you trying to use the new hard drive to load an operating system? Or just plug it in to the SATA header as a storage drive.
m
0
l
May 29, 2010 1:15:36 PM

Just trying to use it as a storage drive. I bought a WD 1.5 TB green drive. My SATA works with my SATA DVD Burner, but I don't have any other smaller SATA Drives to try testing it with. I've done everything I can possibly think of. I upgraded the BIOS to the last version released for my Mobo, and using CPU-Z it shows that it is running that version now. I've upgraded to Service Pack 3 for windows. I even went and downloaded new drivers for the Silicon Image SATA Raid Controller device in windows. None of it helps. As soon as the computer detects the HD in POST, it freezes.

I also tried swapping up my SATA HD and my SATA DVD Burner. If the DVD Burner is set in Port 1, the computer sees it first, then sees the HD and freezes. If the DVD burner is in port 2, the computer freezes as soon as it sees the HD and never even lists the DVD burner. So it's freezing up the second it spots the HD.
m
0
l
a b Ĉ ASUS
May 29, 2010 3:44:21 PM

Does the 1.5TB drive work properly in another computer? I have the same MB BTW.
m
0
l
May 29, 2010 5:09:47 PM

I don't know for sure but didn't think it possible to set up a raid anything if you only have 1 disk.
Plus don't you need to load the mb RAID drivers?

I've got an old MSI mb and set the BIOS SATA for IDE mode. Is that an option on your mb?

m
0
l
May 30, 2010 3:21:40 AM

Nope. I don't even have SATA options under my BIOS. Except for a box asking if I want RAID or SCSI to boot first. Honestly I'm just gonna buy a cheap PCI SATA Controller card... if it won't work through that I'll just return them both and get my money back. I'll just stick with IDE HD's for now. They work at least.
m
0
l
a b Ĉ ASUS
May 30, 2010 4:22:13 AM

DiturbedHLC. A floppy SATA driver disk is need to install a SATA hard drive. I went through this last week in this thread. If you read my posts near the bottom of the thread, I explain how to make a floppy SATA driver disk for the board which I have owned for years. Otherwise, buying a SATA controller card sounds like a good idea.

http://www.tomshardware.com/forum/274645-30-asus-a7n8x-...
m
0
l
!