Sign in with
Sign up | Sign in
Your question

WD2001FASS not detected in bios on asus p5b delux

Last response: in Storage
Share
May 30, 2010 9:40:21 AM

I bought 2 new hdds both from western digital. a 600gb velociraptor and the 2tb wd2001fass. I pulled all the old hdds out ( will worry about backing them up later). Installed the 600gb drive as the boot drive, got win7 x64 installed and everything was working great.

When I tried to install the 2tb drive it is not detected in bios or windows. I have tried changing the sata port, using the jumper to force 1.5gb/s. I also have an external usb adapter for sata drives and it wont load with that either (though it does spin up). Just to make sure that adapter still worked I put one of the old drives on and it loaded right up in windows. I also tried disconnecting the sata cord (since it causes the boot to freeze when auto detecting ahci drives) and connecting it once it gets past that part. When I go into disk management in windows it does show that drive but when I try and initialize it, it says it cannot due to an i/o problem. I have this all setup with an asus p5b delux, in the past I have had little issues when using different hdds but one of the fixes I had tried with this drive fixed the problem with the others.

The bios is also up to date with the most current updates from the asus website.

This mobo has been a pain in the 2 years I have owned it but I do not want to upgrade to a new board with my current cpu, and cannot afford a new board and cpu.

Any help is greatly appreciated and if I left out any details that will help solve the problem, please let me know.
a b G Storage
May 30, 2010 6:01:59 PM

Did you format the 2Tb drive?
If you don't have drive installed when installing windows in AHCI mode, it will not operate in that mode after installation. Probably your best bet is to install all drives you plan on using in the machine and reinstall windows in AHCI mode.
m
0
l
a b G Storage
May 30, 2010 6:07:53 PM

Did Western Digital have any comment on this? I noticed you also posted on Asus forum.

I am wondering if it is possible to set a max size flag in the drives firmware? Essentially losing some drive capacity to ensure compatibility with the MOBO.

Although it seems as though the drive should work with this board, who really knows. Sort of defeats the purpose of the 2TB drive, but its a diagnostic step.
m
0
l
Related resources
May 31, 2010 2:38:42 AM

I posted the same thing on both the Asus and WD forums, figured if there was an easy answer one of the three places would provide it. Also sent messages to tech support for both Asus and WD. That was yesterday and I will probably not hear back until tuesday.

But tonight I tried using the WD data lifeguard diagnostic (just to see if that would find it), the dos version on a cd booted up but did not show this drive, the windows version is for x86 so that didnt load. There are no firmware updates for the hdd avail from wd, they also do not have any drivers that I could find. The drive is not formatted, cannot get bios to find so it is not available in the windows 7 cd boot up. Its odd because I was able to get it to show up in windows as an unknown drive. but I have it hooked up/loose in the case and was holding the drive through booting the system up and windows starting up and at no time do I hear/feel it spin up, the only time Im able to get it to do so is with the usb adapter.

If I'm missing something any help is greatly appreciated. As of now Im thinking something is wrong with the MOBO not supporting this drive or bad drive. I did try the usb adapter on a different pc and got the same results, but I have not tried opening up the wifes comp to test it yet.
m
0
l
May 31, 2010 2:40:22 AM

Also, I have been trying everything in both bios IDE and AHCI modes, with and without the 1.5gb/s jumper and with and wihtout the velociraptor hooked up and have been changing sata slots.
m
0
l
a b G Storage
May 31, 2010 12:12:31 PM

This is very interesting. Please post the responses (if any) from Asus and WD please. My knee jerk reaction is to blame the mobo/bios, but then this would be a more common problem across many platforms, which googling doesn't seem to support, so maybe it is as simple as the drive being defective.
m
0
l
May 31, 2010 9:20:06 PM

Will definitely post any response from them. I have a feeling its going to just be a doa drive. I just hope they will replace with no problems.
m
0
l
June 1, 2010 3:41:49 PM

Contacted Asus earlier today just to make sure there was no known issues with this drive and the P5B Delux, there were none. Contacted WD and after explaining each thing I tried I was told the drive was bad and they will RMA it.
m
0
l
June 5, 2010 6:45:38 AM

Received a replacement drive in the mail today directly from WD, Installed the drive, started the system and it was immediately recognized by windows, formatted it and good to go.
m
0
l
!