Sign in with
Sign up | Sign in
Your question

No Power - GIGABYTE GA-EP45-UD3P

Last response: in Motherboards
Share
April 21, 2009 1:32:02 AM

I connected my Corsair 650TX to my GA-EP45-UD3P using the 8 pin (2x4pin)12v power and the one 24 pin ATX board power connector. I have absolutely no power, the PSU fan doesn't spin ... Absolutely nothing. When I test PSU using Corsairs troubleshooting (paperclip test), the fan spins up as expected. I pulled everything out except for the CPU (Intel E8500) and still nothing. I just started building this so it's never actually worked .... Any guesses or suggstions on how to troubleshoot?
a b V Motherboard
April 21, 2009 1:56:41 AM

Pull the MB out of the case. Set it on an anti-static surface. Install one memory stick in slot 0, install your video card. Make sure you have identified the two pins for the power on switch and have hooked up the P/S correctly to the MB and video card. Take a screw driver and short the two pins. If all is hooked correctly and all the parts are good, you should get power on and video output...
April 21, 2009 2:09:48 AM

Before you dismantel everything.

Plug everything in that's required to boot without error (cpu, video card, memory, and the psu of course).

If the PSU has a separate switch, flick it to on. WAIT, 1 minute. That's right do nothing for 1 minute. After the minute passes try turning it on.

You have to do this every time you turn the PSU off or unplug it from the wall.

I've built 3 computers on Gigabyte motherboards, and this tricked me every time (before remembering, "oh I got to wait").
April 22, 2009 6:10:59 PM

Check it's in the correct pins (PW+/-) ?
!