Sign in with
Sign up | Sign in
Your question

Cant access IDE harddrive, yet BIOS and OS detect it (WIN7)

Last response: in Storage
Share
June 1, 2010 10:48:15 PM

My main hard drive is a SATA 80gb that I run everything from. I also have an old IDE hard drive (13.6gb) with random text and media files. I clean installed Win7 yesterday (coming from WinXP) and now I am unable to access my IDE drive.

Under WinXP I had the SATA and the IDE set to master, which worked fine. When BIOS did not detect the IDE drive the first time around after I installed Win7, I switched the IDE to slave and was then able to detect it in BIOS and in Win7 (got the automatic driver install popup after login for IDE storage device), yet I see no way to actually access it.

Not sure what to try next. The IDE storage is listed in device manager and everything, and I hear it fire up when I access its driver information.
a c 99 G Storage
June 1, 2010 11:33:44 PM

Try setting the jumpers on the IDE drive to "cable select" , and connect it to the end of the IDE ribbon.

Else, you already did my next 2 suggestions:

Check to see if your "IDE ATA/ATAPI controllers" have the drivers installed, in Device Manager.

Check "Disk Manager" to see if Windows sees the hard drive at all.
m
0
l
June 2, 2010 12:06:06 AM

I switched the jumper to CS and booted up but the problem remains the same.

If I go to computer management -> storage -> disk management I see:

Disk 0 |
Basic |
12.67GB | 12.67GB
Online | Unallocated



Below that is Disk 1, which is my primary SATA. So its deffinitely there, I just dont know how to explore it.

Just so you dont have to ask, yes there is data on the disk, I'm positive I did not format it. its max capacity is 13.6GB
m
0
l
Related resources
a c 99 G Storage
June 2, 2010 2:28:21 AM

By that information, the drive is not formatted.

Or at least formatted in a way Windows 7 can see. And Windows 7 should be able to see all (FAT, FAT32, NTFS).

For instance, my Disk 1 shows; Basic; 931.52GB (even thought it is 1 TB); Drive name (drive letter); 931.52GB NTFS; Healthly (Primary Partition).

I'm afraid if you do anything to the drive (i.e. right click on it in Disk Manager, and choose "New Simple Volume" that you would loose everthing on it, because it would then require you to format it to use it.

From here, I'm lost! :( 

Maybe you can contact one of the "experts" in the hard drive forum to help (i.e. 4ryan6, randomizer, r_manic, or arthurh).
m
0
l
a c 342 G Storage
June 2, 2010 2:54:42 AM

Let's review how to set up IDE connections. Any IDE port and cable can support TWO devices, so each of them requires a unique identifier. This is done with jumpers on pins on the drive's back edge to set it to either the Master or Slave role. EVERY IDE port MUST have a Master to work. IF it has two devices, the second unit MUST be a Slave. The only exception to this (not really an exception) is that you can set BOTH devices on a port to "CS"; then the one plugged into the END of the cable will be the Master. NOTE that on some older drives the jumper setting may be different for "Master with No Slave Present" and "Master with Slave", so read the drive's label carefully. Hint: IF you put both a HDD and an optical drive on one IDE port / cable, it is recommended that the HDD be the Master and the optical the Slave.

So, set your IDE drive that way. If you have a second device on the same IDE cable, set it properly, too. NOTE that there is no such thing as a Master for a SATA drive. So you could not have had a SATA Master disk. You probably did have your SATA HDD set up in BIOS as the main boot drive that becomes C:, but that does NOT make it a Master.

Now, if you got the connections right, check in BIOS whether the IDE port is Enabled. If it is you should be able to "see" it in BIOS. If you have an older mobo, some of them did some interesting trade-offs between IDE port and SATA port availability, so be sure the ports for both HDD's really are both Enabled. Then check the Boot Priority Sequence and ensure it uses your 80 GB SATA unit (maybe after the optical unit) but does NOT try to use the IDE unit.
m
0
l
June 2, 2010 2:23:11 PM

Paperdoc said:
Let's review how to set up IDE connections. Any IDE port and cable can support TWO devices, so each of them requires a unique identifier. This is done with jumpers on pins on the drive's back edge to set it to either the Master or Slave role. EVERY IDE port MUST have a Master to work. IF it has two devices, the second unit MUST be a Slave. The only exception to this (not really an exception) is that you can set BOTH devices on a port to "CS"; then the one plugged into the END of the cable will be the Master. NOTE that on some older drives the jumper setting may be different for "Master with No Slave Present" and "Master with Slave", so read the drive's label carefully. Hint: IF you put both a HDD and an optical drive on one IDE port / cable, it is recommended that the HDD be the Master and the optical the Slave.

So, set your IDE drive that way. If you have a second device on the same IDE cable, set it properly, too. NOTE that there is no such thing as a Master for a SATA drive. So you could not have had a SATA Master disk. You probably did have your SATA HDD set up in BIOS as the main boot drive that becomes C:, but that does NOT make it a Master.

Now, if you got the connections right, check in BIOS whether the IDE port is Enabled. If it is you should be able to "see" it in BIOS. If you have an older mobo, some of them did some interesting trade-offs between IDE port and SATA port availability, so be sure the ports for both HDD's really are both Enabled. Then check the Boot Priority Sequence and ensure it uses your 80 GB SATA unit (maybe after the optical unit) but does NOT try to use the IDE unit.



I set the IDE drive back to master, and it is the only drive on that IDE cable. Just as before I see the drive in BIOS, I see it in device manager and computer management -> storage -> disk management. But it is not accessible under My Computer. Im going to reboot and look for another clue in BIOS or during post.

EDIT: the drives display as follows during post:

IDE Channel 0 = Master WDC WD136AA-35BAA0 ATA device

IDE Channel 2 = Master WDC WD800JD-75MSA3 ATA device (boot device, 80gb)
m
0
l
a c 342 G Storage
June 3, 2010 2:51:10 AM

Good, that's all working well, but you still can't access the older 13.6 GB unit. Tell us what you see in Disk Management. Specifically, look there in the LOWER RIGHT pane - it SCROLLS so you can see all hardware devices - and you should find a horizontal block representing it. At the left end will be a small label sub-block with a name like "Disk_1", a size like 13 GB, and a couple other things. To the right of that will be one or more sub-blocks, each representing one Partition on the HDD unit. (You may have only one.) Look at the information in that Partition. It should show you a volume name like "Harry's Disk" that you gave it at some time long ago, a letter name like "E:" in brackets, a size, a File System (NTFS or FAT32, most likely), and a health status.

The two most common problems I see around here are the name and the File System. If it has no letter name assigned, Windows cannot access it. So if that's you situation RIGHT-click on the Partition and choose a letter for it that's not already in use. Then back out of Disk Management and reboot so Windows can begin to use this name.

If it has a letter name, look at the File System. What is it? If it is called "RAW", what that usually means is that the data on it are generally OK, but some of the Partition information contains errors and Windows can't figure it out. If that is your problem, search around here on Tom's and elsewhere on the web specifically for how to recover files from a "RAW Format" drive. If Disk Management tells you the disk is not Formatted and should be now, DO NOT FORMAT THE DISK! Doing that would destroy the directory structure and make file recovery much more difficult. Use file recovery or Partition Recovery tools first.
m
0
l
June 5, 2010 8:33:12 PM

I used "find and mount" freeware to access the hard drive. It was painfully slow but it did the trick, and thankfully the amount of data I wanted to retrieve was less than 1GB.
m
0
l
!