Sign in with
Sign up | Sign in
Your question
Solved

Hard drive has a mysterious problem...

Last response: in Storage
Share
June 3, 2010 7:53:53 AM

I have a WD 500gb Black ed. sata HD that was recently part of a RAID array that was working just fine. I decided to take the RAID apart and just use the HDs seperately.

One of the HDs that was in the array is now working perfectly. The other now has a strange issue.

If I boot windows 7 up (which is installed on a different HD) with the HD connected, windows can see, format, and use the drive. The problem happens when I try to install windows on it. The windows setup seems completely unable to detect the drive. It detects other drives if I plug them into the same sata port. If I try to install Ubuntu it does the same thing. No matter what I try, I can't seem to get any operating system to detect this drive during the installation process, they can only see if I boot into the OS from a different HD. I have run both a WD and Seatools diagnostic test on this drive and they find nothing wrong. I am currently doing a full (not quick) format in windows to see if that helps.

Anyone have any ideas as to how to get windows/ubuntu installation processes to see this drive?
a b G Storage
June 3, 2010 8:04:27 AM

Yeah, format the drive. Then the installer should read it.
m
0
l
a b G Storage
June 3, 2010 11:47:31 AM

Is the drive when connected by itself, detected properly in the BIOS?
If so during the OS install the drive should appear, allowing your to repartion and format.
m
0
l
Related resources
June 3, 2010 5:54:07 PM

Ok, still no luck after a full format. Bios is detecting the HD just fine. Windows (when booted) can detect the HD just fine.

I can literally unplug this drive during the windows setup when it says it can't find it and plug in another one in the same exact spot with the same cables and it push refresh and it will find the other drive. Then I switch them back out and push refresh and get nothing.
m
0
l
a c 348 G Storage
June 4, 2010 2:46:59 AM

When you try to install a Windows OS on this re-used drive, at the very beginning of the process are you using the menu options to find and DELETE any Partitions it already has on it? Windows Install goes looking for HDD units with Unallocated Space in which it can Create a Partition, Format it, and Install to it. But your re-used drive already has been Partitioned and Formatted so it has NO Unallocated Space.
m
0
l
June 4, 2010 5:36:26 AM

Got it figured out. And just so you know, the windows setup has no problem finding formatted drives with all space already allocated.

I had to use the windows cd's command prompt to use a program called diskpart.exe to partition the drive and set the partition to active. At first, diskpart.exe couldn't do that (for some reason it refused to select the partition windows had made), but once I booted into windows and deleted the partition (and left the whole drive as unallocated) then went back into diskpart.exe it was able to create a new partition. I then set that partition to an active status with the command "active". After that, the windows setup had no problem detecting the hard drive, deleting the partition I had just made, creating a new partition, and then installing onto that.

That was some weird crap.
m
0
l

Best solution

a c 348 G Storage
June 4, 2010 5:25:59 PM

I agree. So, Windows Install could not recognize and work with a Partition that was not already marked as "Active", even for the simple task of Deleting it! You had to use Diskpart to make it Active so it could be handled. Weird crap is right!

Thanks for letting us all know how you solved this puzzle.
Share
June 19, 2010 7:09:37 PM

Best answer selected by pogimabus.
m
0
l
!