Sign in with
Sign up | Sign in
Your question

Slow FPS while playing C.Strike 1.6 in Steam

Last response: in Graphics & Displays
Share
January 10, 2009 9:44:48 AM

Hello everyone, i have got some probz here, i just recently upgraded my gfx to nvidia xfx 7900gs, i use to play with my old gfx which is ati radeon with 80 to 90 fps. I cant really remember the model of the old gfx i owned anyways the old gfx i have is not as good as xfx 7900gs. After upgrading to xfx 7900gs i'm playing C.S 1.6 at 60 fps only. whats happening?
This is the specs of my computer:-

PSU : PowerLogic 450watts
Monitor : LG Flatron L1952S (19 inch)

Main Circuit Board
Board: ASUSTeK Computer Inc. P4P800SE Rev 2.xx
Bus Clock: 133 megahertz

Processor
2.40 gigahertz Intel Pentium 4
16 kilobyte primary memory cache
1024 kilobyte secondary memory cache

Memory Modules
3072 Megabytes Installed Memory

Operating System
Windows XP Professional Service Pack 2 (build 2600)


------------ Please Help ----------
January 11, 2009 10:44:53 AM

have you downloaded the latest driver for the card? and force off vertical sync in nvidia controls and see what your fps_max is at in console.
January 13, 2009 4:23:28 AM

Yes, i have already downloaded the latest driver for the card and now after force off the vertical sync in nvidia controls the fps now is at 99fps. Thanks. My fps_max in console is adjusted to 99 way earlier :)  So, thanks alot. Between just another question if you know how to fix it. My window resolution is 1024 by 768. but my CS resolution i used is 800 by 600. When i lauch my CS last time before i format my pc, it will automatcally change to 800 by 600 screen. But after i format, it stuck at the resolution 1024 by 768 and the screen for my CS is smaller then usual. In order to make the CS screen back to 800 by 600 i have to change my windows resolution to 1024 by 768. Any idea on how to fix this crap? A computer noob here.
Related resources
January 13, 2009 5:56:56 AM

hmmm.. don't really understand what you are trying to say, can you repeat that?
a b Î Nvidia
January 13, 2009 6:11:13 AM

So are you playing in windowed mode ? I dont know the game but some give the option when setting up the game, should be under Video or graphics settings in the start menu if thats what it is.

Mactronix
January 13, 2009 11:58:02 AM

opps..sorry! my english is a lil bit sucky. what i'm trying to say is i'm kinda like playing in the window mode. cause my window resolution is 1024 by 768 and my Counter Strike 1.6 resolution is 800 by 600. As soon as i launch my Counter Strike it appear in a smaller window form. got it??
a b Î Nvidia
January 13, 2009 1:15:35 PM

So what you need to do is switch it to full screen mode which should b eunder the Video or Graphics settings in the games start menu.
Or just up the settings in game to be 1024X768 and it should play full screen by default.
Mactronix
January 13, 2009 2:43:30 PM

ya just open up the game go to options>video>uncheck run in window, and then change resolution to 1024x768...make sure display mode is on normal not widescreen and you should see 1024x768 in the resolution part.
January 13, 2009 4:07:19 PM

Also, on a 19inch, you can play at 1152 or 1280 without problems. You can also set your fpsmax to 250 or whatever high number you like so that it doesn't cap you at 100fps. It might seem a bit more "smooth" afterwards.
January 14, 2009 10:44:12 AM

if u want some more added fps type in Developer 1 into your console
January 14, 2009 12:05:56 PM

thanks all for the informations. i have good fps now and smooth running CS game. the only thing is that i have to kept changing my window resolution to 800 by 600 every time when i wanna play CS. By the way My CS option / video (run in window mode) is untick. And i'm not used to play at 1024 by 768 cause everything is just too small for me. harder for me to get HeadShot. :)  so, hopefully someone will get to help me to solve the window resolution thingy.so far its remains unsolve. :( 
May 28, 2009 7:09:24 PM

You need an NGO version of the drivers.

http://www.ngohq.com/home.php?page=Files

I was stuck at 60fps until I did this.

All other programs still work fine.

(If this solution works for you = please post to other relevant forums and spread the joy of 100fps)
May 28, 2009 8:38:27 PM

Vsync off if you want more FPS, although since the LCD can't re-draw itself more then 60 times per second, any extra effect of 100+ FPS would be the placebo effect in action.
May 29, 2009 4:13:44 AM

Placebo effect is well worth it. In medicine placebo accounts for approximatelty 25% of all medical interactions.

As for placebo, I believe the human eye has a limited fram rate...nonetheless, my gameplay bounded back to its usual level when I applied this driver.

I think you should try it yourself before speculating it was the power of the mind power that improved performance. ....by your logic I see a possible flip side for the changesI experienced...perhaps it was an divine intervention??

Whatever it IT WORKS. Game performance improves in CS 1.6

a b Î Nvidia
May 29, 2009 7:50:06 AM

Human's eyes are all very very differant and there has been no medical study that says anything about any limits. For starters every single persons optical nerve would have to be exactly the same length for the impulses to be sent at the same speed for everyone. and as they are not its plain imposable to measure such a thing.
Adversly a LCD physically can not draw frames faster than its refresh rate, be it 60Hz,75Hz thats your limit. You can of course get monitors with higher Hz, there are a couple of 120Hz sets out now and so that would then be your limit.

Mactronix
May 29, 2009 8:24:12 AM

Regarding the problem at hand and what is possible.
I have a 120Hz Samsung 2233 monitor and was still frames per second limited until I applied the Optimised NGO drivers.

Hope this helps.
!