Sign in with
Sign up | Sign in
Your question

Reusing Hitachi SATA drive

Last response: in Storage
Share
June 6, 2010 2:36:55 AM

Hello,

I just upgraded my lenovo laptop with a 250GB SATA Harddrive, and thought I would reuse the old 100GB hitachi SATA drive as an external drive, by putting it in an enclosure.

The instructions with the enclosure tell me to make sure the jumper is set to master, but I cannot find jumper on the drive.

When I connect the drive the computer installs a driver and displays a USB to ATA/ATAPI bridge
under "devices and printers" but does not show a drive under "my computer". the instructions with the enclosure suggests I format the drive, but I do not want to do this because it still has some programs and data that i want to keep from when it was the internal drive in the computer.

Can anyone offer suggests of what I should be doing?
a b G Storage
June 6, 2010 9:32:10 AM

What model hitachi, enclosure, operating system?

The jumpers on an SATA drive are usually for limiting speed, if you have changed these, put them back. SATA drives do not have Mater/Slave jumper settings like IDE drives do.

If the drive is installed in the enclosure properly and there is nothing wrong with the enclosure the drive should be detected under device manager/ disk drives as a USB device. Then you can check under storage management to see if it is recognized properly/partitions intact. At this point though the drive should have appeared under My Computer.

Try the drive in another machine to test.
Look on the enclosure makers web site for software, drivers and supported operating systems.
m
0
l
June 6, 2010 4:20:06 PM

Thanks for the response. Drive is a Hitachi HTS72101 0G9SA00. Enclosure is Sabrent EC-UST25. Current operating system on the computer is Windows 7 32 bit, but the disk I am trying to reuse was the internal C drive on the commuter previously when it was running Windows XP.

I did not change any jumpers as I could not find any.

Currently when it is connected, it displays as USB to ATA/ATAPI bridge in devices and printers. When I click on this USB to ATA icon -> properties -> hardware, it shows the type of drive correctly. When I then click on properties button on the hardware tab intitially all the properties (partition style, unallocated space, etc) are blank. If I click on populate a couple times, it displays those properties. But I still do not see the drive when I click on My computer.

I will try your suggestions and see what happens.

Thanks again.


m
0
l
Related resources
June 6, 2010 4:41:22 PM

I just discovered that when I click on Computer Management -> Storage -> Disk Management is displays the Hitachi drive as "offline because it has a signature collision with another disk that is online.

Thanks again and I will attempt to use the drive on another computer as you suggest.

m
0
l
June 6, 2010 5:21:46 PM

I found a solution to the problem, by googling hd signature collision and nosing around on some of other sites.

The key was that Computer Management -> Storage -> Disk Management is displays the Hitachi drive as "offline because it has a signature collision with another disk that is online.

It was not apparent, that there was anything to click, but when I right clicked on offline, it gave me the option to select online. this did the trick and assigned it a drive letter D.

Apparently the "signature collision" meant it was trying to treat the drive as C and that was already taken.

Hope this might help someone else.

m
0
l
!