Sign in with
Sign up | Sign in
Your question

Far cry 2 choppy in ultra high, is that normal?

Last response: in Graphics & Displays
Share
January 11, 2009 11:00:16 AM

i have 280 gtx
4 gb ram
q9550 core.
tx 750 psu
when i set far cry 2 on ultra high i get a bit of choppines.
when i stand and looki ts smooth
when i walk i get a tiny chopines every few secs.
if i drive\sail i get lots more.
is that normal for my setup?
a c 169 U Graphics card
January 11, 2009 2:43:09 PM

That 1 second preiod lag happens sometimes,i had this problem when i had a 8800GTX with MOH:Airborne game.Its nothing serious dont worry :) 

However do u have this issue with other games?
January 11, 2009 3:54:10 PM

With it being on ultra high you certainly can expect some slowdowns but what confuses me is that you get it simply by walking around and your still playing on ultra high. If you have this performance issue then combat must be hell for you with the fps drops. I suggest you lower the detail level.

I would much rather have a smooth game play experience with lower graphical settings than to have a choppy frustrating game
Related resources
January 11, 2009 6:28:36 PM

i dont get it in combat at all, i only have it when i drive or run fast. most people wouldnt notice it.
yes its only in far cry and only in dx10.
a b U Graphics card
January 11, 2009 6:54:15 PM

For it to happen only when he moves makes me think it has something to do with game loading new models/textures. Could be the way these tasks get handled in DX10 compared to DX9 ...
January 11, 2009 7:56:23 PM

what resolution are you using and what driver version?
January 11, 2009 11:53:53 PM

What setting of AA and shadows do you have it set to? Ultra high shadows makes my setup really choppy. The FPS holds steady but it skips frames a lot. I have to run with VH shadows.

Same here though. If the game ever gets choppy it is pretty much always when driving. It gets worse when I drive through a jungle area (more shadows I assume are the culprit).
January 12, 2009 7:24:02 AM

i took aa down to 0 last night ( i never ever knew what aa did) and choppiness went down 90%.

my drivers are 180.48 resolution is 1650x1080
January 13, 2009 4:22:43 AM

I'd say drop down to very high and put 2 or 4x aa back on. It will look better than ultra with no aa.
a c 169 U Graphics card
January 13, 2009 5:36:28 PM

No,because AA takes away jaggies ,thats AF which makes the game more realistic.
Also in some resolutions like 1680x1050+ u wont need AA much since u wont ntoce alot of jaggies.
January 14, 2009 10:02:43 AM

Open console [press ~] and type: showfps 1
If it says that e.g. your framerate is over 40 fps then type in console: gfx_maxfps 40. This should help. And you won't need to lower the AA to 0.
a b U Graphics card
January 14, 2009 11:15:57 AM

you can also tweak some forceware settings. you might have unintentionally set VSYNC ON on all games, which may have something to do with movements.

or maybe its the dx10 mouse lag that makes it choppy.

try changing your resolutions but dont press accept, press cancel instead. sort of helped on my end.
!