Sign in with
Sign up | Sign in
Your question

Abit AV8 3rd Eye - BIOS does not detect SATA drive

Last response: in Motherboards
Share
April 28, 2009 8:32:47 PM

My second computer runs with the following

Abit AV8 3rd Eye (VIA K8T800pro/VT8237)
Athlon 64 3200+
2Gb Apacer RAM
GeForce 7800gt (AGP)

My old IDE HD went kaput so I went out and bought the Hitachi P7K500 sata drive.

To start, I DO NOT wish to establish a RAID. I only wish to run a single SATA drive.

Unfortunately, there seems to be a lot of problems with the chipset on this board and sata, and very few answers. I thought I'd come and take a stab in the dark.

When I go into the BIOS, my new drive is not detected. I have seen forum posts before that said sata drivers need to be installed for this motherboard in order for sata drives to be detected. However, it seems that the driver is just for sata raid (which I do not want or need). There are no clear settings (at least to me) in the BIOS that would be responsible for making the drive appear.

I had read that there was a utility for the Hitachi deskstar HDs that would allow you to change the data transfer from 300 to 150mb/s, since that is all my motherboard will work at (150). However this utility does not detect the drive either. I had used a Seagate Barracuda SATA drive previously as a secondary storage drive and, interestingly, I was able to activate it through Disk Management in Windows but it never did appear in BIOS. My problem, at present, is that I have to install windows on the SATA drive.

So, my goals are as follows:

1. Get BIOS to recognize the sata drive.
2. Install Windows XP on the sata drive.

FYI, the BIOS has been updated to the most recent version.
April 28, 2009 11:07:26 PM

interesting, I am having the exact same problem with the same motherboard. The drive I bought however, is a 1.5tb seagate drive. I do not believe that the SATA drive should show up in the BIOS as there is no place for it. There are only 4 entries in the BIOS for disk which is only enough for the PATA drives - two masters and two slaves. If you were installing windows on this drive, then you would likely have to install the SATA drivers, but I wouldnt think you would have to if you were just using it as a secondary storage drive.

a few questions for you:

did you have to use a FDD to update your bios or do you have an alternate method?
what size was your segaate that you had working?

you might want to try clearing your CMOS with the jumper on the MB, sometimes that helps with new drive detection. good luck! I'll let you know if I figure out the issue on my end any maybe it will help you too :-)
April 29, 2009 9:58:21 AM

Well, actually I am trying to install Windows on that drive. The detection of the old Seagate (250GB) sata drive was not a problem since windows was already installed and I was able to activate the HD via Disk Management.

My problem is that when I try to install Windows on the new drive it does not get detected during the windows setup program. I tried using nlite to add the SATA driver to the windows installation disk but that did not seem to help. I pulled an old floppy drive out of a relic that has been sitting in my basement and tried to install the SATA driver using the 3.5 floppy that came with the mobo but I got an error "file txtsetup.oem caused an unexpected error (1024). I tried switching the sata cable as well.

I have not cleared CMOS at all so I suppose I could try that.

Thanks for your reply, and given that I am not just using the drive as secondary storage, do you have any other ideas?
Related resources
April 29, 2009 11:03:32 AM

I had that same problem with that board and a Samsung SATA2 drive, it would only detect the drive on a warm boot, never picked it up booting from cold.

I'll take a look at the bios when i get home from work and see how I set it up as I used it as my windows drive for over a year, but I always had to ctrl-alt-del after first powering on
April 29, 2009 1:21:31 PM

Hmmm. That's interesting. I am fairly sure that in all of my testing/retesting I have done a warm boot and still not been able to find the drive.

I cleared the cmos as well and that did not have any effect.

I echo the sentiments of many, many others who have posted in many forums regarding this similar issue; VIA sucks.
June 12, 2009 6:57:40 AM

OK, you all may not like me after this ;)  .....I have a BioStar K8M800+ with AMD Dual 4600, 2GB RAM and VIA VT8237+ . I just a few moments ago finished installing, initializing and formatting an Hitachi 500GB P7K500 SATA drive. The board is SATA I (1.5Gb/s) and the drive is 3Gb/s.

The drive seems to work fine...so far. The worst problem I had was finding the right size screws to mount it. I did not have to download any SATA s/w. I was worried about the "jumper" issue for taking the drive from SATA II to SATA I, but it's not clear that's something I need to worry about....so far

I know Wiki talks about the VT8237 as a problem for this, but maybe since my board has the plus version, VIA has solved whatever problem there was.

Having said all that...my plan is to clone my current WinXP system to the P7K500 and make it the boot drive. I guess that will be the BSOD test, so to speak. However, based on the problems I've read about here, none of which I've seen so far, I feel optimistic that I should not have a problem. "Proof is in the pudding", tho :) 

BTW - I read somewhere that someone made a "lucky" guess about a jumper they modified on the HD that made the change from SATA II to SATA I (in case the computer/HD protocol couldn't do it). Anyone here know anything about it?

I'll post back here once I have this next "phase" completed.

Cheers...Steph
June 12, 2009 12:22:48 PM

If your drive seems to be working then you are far better off than I was.

I forgot to post back here to indicate that I had finally solved my riddle.

It was simply a matter of switching my new drive to SATA 1.5 on my other computer (that was able to detect SATA in the BIOS. Then I saved the newest SATA drivers to disk and all was well during the fresh installation of windows. Pain in the butt though. I had to go out to my van, where I had just put an old, old computer (a 486, yikes) for taking to the dump and steal the a\: drive out of it, hoping that it would somehow work still.

Anyway, hope your drive works well for you.
June 12, 2009 12:24:49 PM

I forgot to mention that the sata driver disk tha thad come with my mobo was corrupt and was the reason I was receiving the error I had mentioned previously in this thread during installation.
June 12, 2009 8:02:30 PM

I appreciate your specific situation, but it sounded as if someone else (plus others who have posted elsewhere...if my old, fading memory still serves me ;)  may have been having similar problems. I'm glad yours worked out.

As a comment to the posting above regarding the SATA drive having no place to show up in the BIOS listing....as a point of interest, in my BIOS one would think the same thing. However, once I had the drive installed and basically working, my BIOS showed 2 new listings (in addition to the other 4 IDE devices..2 HDDs, 1 DVD Player, 1 CD-RW): IDE 0 Master (where my Hitachi HDD was installed) and IDE 0 Slave. Also, my BIOS has a place where I can specify the priority of which device to use for bootup. Included on the list is the new Hitachi SATA HDD. I guess if my new drive never showed up in the BIOS, the BIOS would not give me that option as a boot up device.

For me, as I expected, the shortest distance between 2 points is rarely ever a straight line :( 

I'm not really having any serious problems, but it seems that having installed the SATA drive has caused my system performance to take a pretty good hit. Not sure why that is. I've checked for the latest SATA drivers for the VIA chip and I must have installed that somewhere along the way (prob'ly expecting to move to SATA).

I did a simple file transfer test just to see if the drive would wiggle. The file went from a PATA drive to the SATA drive. It was 3.3GB and it took a minimum of 25 mins (maybe 2.5MByte/sec)!! I then did a transfer of this same file from partition to partition on the same SATA drive. Time was 2 mins. max. Then as a last test, I transferred this same file to a Fedora box I have connected on the same network (100MB). It took about the same amount of time (actually less) than my 1st test (PATA to SATA). I did use Hitachi Features Tool to set the drive to the 1.5GB limit hoping that might help. Nothing apparent in performance. It's not clear to me what's going on, but I am certainly open to ideas and suggestions.

A piece of info I wanted to add: In looking at task manager, I noticed something kinda funky. At the bottom of the window where the CPU Usage is shown, there have been times when this number shows 30-50%. But when I look at the list of processes, systemidle shows 90+% meaning nothing else is really running. Don't remember seeing that before I installed the new SATA HDD. I suppose it's possible I picked up a virus somewhere along the way....but the odds of that are low.

I have yet to clone my WinXP drive onto this SATA (ultimate goal) because a) I'm concerned about performance and b) I'm still trying to figure how to do that. Tried using Maxtor/Seagate's MaxBlast, but it seems to hang at some point along the way (prob'ly because if the destination isn't a Maxtor/Seagate drive, it may not know what to do with it). Looking into Clone-Zilla, but Linux is something with which I'm still trying to get familiar. Open to suggestions on this, as well.

I'll continue to keep this forum posted on my progress in case my trials and travails can be of help.

Cheers...Steph
October 4, 2009 8:10:31 AM

My Mother Board AV8 3rd eye does not detect the WD 500 GB, SATA 3 Gb/s, 16 MB Cache, 7200 RPM. I can see there are 6 list of IDE on bios but it does not shows the SATA dive.
October 4, 2009 5:12:16 PM

Hi,

I realized I never got back to provide a response to this posting (couldn't keep track of where I posted for some help :( 

Turns out my problem had nothing to do with the Hitachi drive. I discovered one of my other drives (Maxtor 200GB) was acting up. Once I removed that from the system, everything functioned as expected (~150MB/Sec to/from the Hitachi drive).

I'm not sure if this helps you at all, but good luck.

Cheers....Steph
December 5, 2009 8:19:47 AM

New SATA drive not recognized by an old AV8 motherboard.

I had the same SATA disk detection problem with Abit AV8 motherboard and a new Western Digital Caviar Green 1Tb disk. Based on the comments on this thread, and some trial, I found a solution:

- slowed down the disk interface from 3Gb to 1.5Gb by putting in a jumper to pins 5&6, eg the pair second from left
- switched the SATA cable to a connector with earlier had a well-working SATA drive, and connected the old one to the cold connector.

Now both disk are recognized beautifully:) 

December 13, 2009 5:24:28 PM

Another option to try that worked for me.

I have the same mobo Abit AV8 and I finally (after 48 hours) found these fixes



1. Use the slow-down method by setting a jumper


2. Go into bios integrated peripherals onboard ide and DISABLE sata raid rom!

With it enabled it expects to see multiple drives so even though you go into your
TAB screen it gives you a warning and doesnt let you go further.

with it DISABLED it finally recognized my single 160G sata drive and showed in Bios

hope this helps.
February 18, 2010 3:24:04 PM

Hi!
I have the same problem as sewildman50 (first person in this thread).
I tried to install 250Gb Seagate SATA HDD- not recognized by BIOS, I thought it was bad.
Got another 500Gb Western Digital SATA HDD- same problem.
I use an old 80Gb SATA disk now- no problems, but it was installed while I was using an old IDE HDD, which had died since.
SATA drivers that came with this Mobo on a floppy don't help. Neither did downloading newer drivers from manufacturer.
I tried any combination, including using just one and/or 2 of the new HDDs with fresh XP Pro installation and it does not see any HDD at all.
New SATA HDDs don't come with jumpers, can I use one from an old IDE drive?
"Go into bios integrated peripherals onboard ide and DISABLE sata raid rom!"
Tried both disabling and enabling SATA raid rom- no change.
Please help!
Maggie
February 18, 2010 5:19:52 PM

Just to let you know- I found a solution. I put a jumper in to slow down the 250 Gb Seagate HDD from 3Gb/s to 1.5 and now my comp recognizes it!!! I also called tech support for my new Western Digital Caviar SE16 500Gb HDD to find out if I could do the same thing- sure enough, jumper goes to pins 5/6 to slow it down to 1.5Gb/s.
July 29, 2011 9:25:01 PM

where are the jumpers are they on the Motherboard because there arent any on the hitachi hard disk thanks.
August 5, 2011 1:58:23 AM

My problem is that when I try to install Windows on a new disk is not detected in Windows installer. I tried to use nLite to add the SATA drivers for the Windows installation disc, but does not seem to help. I took an old floppy disk out of the relic, which has been sitting in my basement and tried to install the SATA controller uses 3.5 floppy disk with the motherboard, but I received a message "file error caused txtsetup.oem an unexpected error (1024). I tried changing the SATA cable.
Tera OnlineTera Online GoldTera Gold

October 12, 2011 9:04:02 PM

This thread worked for me. I had a newer WD drive that was not getting spotted by the BIOS. I jumpered the drive to run at the slower speed then disabled the VIA RAID in the BIOS and everything came up perfectly. Thanks a lot for this thread. :) 
December 17, 2011 3:28:41 AM

punjedi ---This was spot on.


With the exception of the Hitachi drive not having a jumper. You have to have a new computer to read the Sata 3.0 and use the Feature tool to set the speed back to 1.5. Then follow punjedi's advice. You have to turn off the Sata Rom in bios if you only have one drive.

What would we do without the forums, thanks everyone
!