Sign in with
Sign up | Sign in
Your question
Solved

IDE drive not recognised by BIOS

Last response: in Storage
Share
June 9, 2010 5:39:22 AM

hi
the BIOS on my Dell 8400 doesn't see my IDE drive any more. Windows sees it fine as long as the IDE controller is turned on. This happened after I replaced the backup battery and lost the setup data.
ngm@paradise.net.nz
a b G Storage
June 9, 2010 8:41:44 PM

You may have to enter the BIOS and reset the HDD settings to "legacy" or "IDE/EIDE," then save and exit.
m
0
l
June 10, 2010 12:20:53 AM

treefrog07 said:
You may have to enter the BIOS and reset the HDD settings to "legacy" or "IDE/EIDE," then save and exit.

Thanks - can't find a setting for that though. I have noticed that the BIOS does now see the DVD drive on the primary IDE controller but sees neither if I turn on the Slave IDE ccontroller. Both drives are set to CS and are on one cable (only one IDE cable available.). I'm wondering if it can only show one drive on each controller and I should set one drive to slave and turn the Slave IDE on? I've tried the DVD on master but that didn't change anything
m
0
l
Related resources

Best solution

a c 357 G Storage
June 10, 2010 3:46:02 AM

If you have two devices on one IDE cable, then they are sharing the one IDE port they are connected to. By the way, terminology is this way: there is a Primary IDE port and, IF there's a second one on the mobo, it is the Secondary IDE port. On EACH of these ports there can be up to two devices. EACH port MUST have a Master device if it is in use, and may have a Slave device also. Normally each device has its role set by jumpers. But the alternative is to set both devices on one port to "CS", and then the one on the END of the cable WILL be the Master.

As a good guideline, if you have both a HDD and an optical drive on one IDE port / cable, then the HDD should be the Master on the end of the cable, and the optical drive should be the Slave. So set your HDD and optical (you say they are sharing one cable and port) this way.

Now, there's another thing you need to do. You replaced the BIOS battery and it lost its settings. What you should have done when the new battery was in place was to restore to BIOS a good set of parameters to start with. In BIOS Setup near the end of the menu system is a place where you can Load some settings. Load either the Factory Default set or the Optimized Default set. Then go about changing any particular thing you know needs to be set. Save and Exit from here to finish booting. Shut down and boot back into BIOS Setup. Look now at whether your BIOS sees the IDE drive properly. Usually on the configuration screen for an IDE drive the best option is to set it to AUTO mode so the BIOS gets the required info from the HDD itself. If that does not work, look again near the end of the BIOS menus for a place where you can force the BIOS to Auto-Detect the HDD and let you confirm which set of parameters you want it to use to access the drive. Save and Exit once it's all working.
Share
June 10, 2010 9:43:16 AM

Thanks for that very detailed answer. My own research had led me to about this answer too. I've set the HDD to master and the DVD to slave , turned both IDE channels/controllers on (I think my BIOS calls them controllers but they are both on one cable). Now it sees the HDD on the IDE master channel/controller and the DVD on the slave. All is good. Not sure if restoring to default BIOS settings would have worked as the default for all the disk controllers was OFF.
My reading suggested that for the CS setting to work you need an ultra ATA cable with 80 wires (which has coloured plugs). Maybe that's why it didn't seem to work as mine is a standard 40 wire cable.
m
0
l
a c 357 G Storage
June 10, 2010 5:26:32 PM

You may be right about the cable. Are you sure it is 40 wires? Even though the connectors have 40 holes for pins (one actually blocked off), count across the ribbon - if you get to 20 and you're only ¼ of the way across, it is 80. But yes, you could have one of the older 40-wire cables. The necessary wiring tricks in the cable for CS to work is in any 80-conductor cable, but may NOT be present in an older 40-wire one.

A 40-conductor cable usually will limit the speed of the devices on it to the ATA-66 speed. If your controller and devices are able to do ATA-100 or ATA-133, switching to an 80-conductor cable when you can will speed them up.

Does your mobo have TWO IDE pinouts (connectors)? Usually the term "controller" would refer to the system to handle only ONE IDE port which can support two devices. It probably does not matter, though - having a second IDE controller and port turned on when not actually in use will waste almost no resources or time.
m
0
l
June 17, 2010 10:20:33 AM

Best answer selected by ngmnz1.
m
0
l
!