Sign in with
Sign up | Sign in
Your question

256GB M225 Windows 7 will install on SATA 3.0 but won't boot. ASRock X

Last response: in Storage
Share
June 11, 2010 6:19:41 PM

Hey guys,

Im completely new to using SSDs. I got a new motherboard (ASRock X58 Extreme 3) with the intention of being able to take advantage of SATA 6Gbps from the Marvell SE9128 onboard controller.

I tried putting my SSD on this port and the BIOS and even the Windows 7 installation would recognize it as being present and would even complete installation prior to the first restart. However, once it was time to restart the OS wouldnt load and would be unable to complete installation. I tried changing to ACHI and IDE and neither made a difference.

The only way I was able to get the SSD to work (ala completely install Windows 7) was to put it on the main SATA ports that are part of the X58 chipset. Only then was I able to complete the installation and have a normal functioning Windows 7 operating computer, which is the good news.

Can anyone shed some light as to why this was happening? I really want to be able to take advantage of the additional bandwidth the SATA 3 bus provides.
a c 209 $ Windows 7
a c 415 G Storage
June 11, 2010 7:31:20 PM

Are you able to go into your BIOS configuration and select the SSD as the boot device? If not, there may be a restriction on booting from drives attached to that controller.

What kind of SSD do you have? There are only a very few high-end SSDs that have transfer rates faster than about 300MByte/sec - if your drive doesn't exceed that speed then it's not going to run any faster on a 6Bgit/sec port than on one of the standard X58 ports.
m
0
l
June 11, 2010 11:01:39 PM

Yes, I can select it from the BIOS. Before I got my SSD, I had two regular hard drives running RAID 0 and it had my main OS on it.

SO I know for a fact that it is indeed bootable. I am thinking about getting a 2nd SSD and would run it RAID 0 on the 6GBps, but obviously I want to get it to work first.
m
0
l
a b $ Windows 7
a c 99 G Storage
June 11, 2010 11:34:43 PM

I believe those 6.0Gbps SATA III ports should be backwards compatible with 3.0Gbps SATA II.

I think it's the controller. I've never liked JMicron on my board, but I don't know about Marvell. Could be a driver issue. Try updating driver from mobo website. You may have to install it as a third party drive during OS install. Where the HDD's in RAID on those ports before?

And, like sminlal states, unless you bought a SATA III SSD, you won't see any performance increase putting it on SATA III vs SATA II. Even SATA II SSDs can't saturated the bandwidth, but they do get close. No HDD can even come close. Can't beleive they are selling SATA III hard drives! Remember, they boost max data transfer, but they don't get close! I have examples.
m
0
l
!