Sign in with
Sign up | Sign in
Your question

Hard drive issue, Windows 7 64-bit

Last response: in Storage
Share
June 15, 2010 12:55:48 AM

Hello,

I've been ghosting the forums for a bit looking for a solution to a problem I'm having. A bit of background:

- Had a Iomega NAS external drive that I used to back up my files when I formatted my XP computer to use Windows 7.

- Windows 7 nor the Iomega software could identify the drive after the new OS installed. Long story short, Iomega tech support was useless, and suggested I take the drive out and install internally and recover my data.

- Drive itself is a 1Tb Seagate Barracuda, SATA. I installed as internal, turned the SATA port on in the BIOS and BIOS correctly identifies the drive. The drive is not found under my computer. I do see the drive in Device Manager and disk management.

- I found a suggestion on this forum to uninstall in Device Manager, and scan for hardware changes. I did this, but no fix.

- As I mentioned, the HD is found in Disk Management, but I have no options in terms of changing its drive letter. It does not show what type of file system, just that there are three "Healthy Primary Partitions". When I right click them, my only options are "Delete Volume..." or "Help".

- I downloaded Seagate's Seatools to perform drive tests (Seatools version for Windows, not DOS). The Short generic and Short Self Drive test both pass without issue. Haven't yet tried the long tests.

- I tried two data recovery programs to see if they could see what's on the hard disk. DataDigger found nothing, and cited a cyclic redundancy error. RecoverMyFiles is running as I type this, and is identifying several "unreadable blocks". I hear the heads on the drive clicking over and over as it does this...not sounding great.


I'm worried this drive may have a hardware failure, but haven't yet seen any issue in Seagate's own program so I'm not sure what to think. Not to mention that it would be terrible luck for my hard drive to fail exactly as I back everything up and format..

Any insight anyone has would be greatly appreciated. Thanks for reading!
a c 209 $ Windows 7
a c 415 G Storage
June 15, 2010 6:46:42 AM

Yeah, this is why I avoid RAID and NAS. The more stuff you fiddle with, the more things there are to go wrong. I'm a big proponent of the "KISS" approach...

I have no familiarity with Iomega NAS systems, but I suspect the problem may be that the drive is not formatted as NTFS or FAT. If the Iomega used a Linux-style system internally (seems likely to me, since using Windows would require they pay Microsoft), then you're not going to be able to read the drive under Windows.

You could try downloading a copy of the Ubuntu "LiveCD", burning it to a CD/DVD and booting from it. I understand that it contains drivers for just about every type of file system out there including RAID and chances are it will recognize your disk. If so, I'm thinking you should be able to plug in a second disk and copy your files to it.
m
0
l
June 17, 2010 11:24:29 PM

Thanks for the suggestion, sminlal. I'm downloading the ubuntu iso now and will give that shot once I burn it and boot it.

As a side note/update, I ran the long generic test the other night in SeaTools and again found no issues.
m
0
l
Related resources
June 19, 2010 2:36:17 AM

argh, booting ubuntu from a cd is giving me issues. It gets to the Unbuntu screen and just hangs. I'm searching among the ubuntu forums for a fix for this but I'm a complete newb :|
m
0
l
a c 209 $ Windows 7
a c 415 G Storage
June 19, 2010 6:40:47 AM

I'd make a suggestion if I could, but I'm no Ubuntu expert either...
m
0
l
July 1, 2010 4:12:06 AM

okay, I've been away for a few days but I gave this a try again. I can get ubuntu to run with no issues with the hard drive not hooked up. With it hooked up, ubuntu gets a series of error messages before the ubuntu loading screen, and I hear the hard drive clicking as this is happening. The ubuntu loading screen finally gets up and it hangs, never loading.

This is starting to sound more like a hardware failure, no?
m
0
l
a c 209 $ Windows 7
a c 415 G Storage
July 1, 2010 6:10:43 AM

It is rather sounding like it. Have you tried using different cables and/or ports for the suspect drive?
m
0
l
July 2, 2010 2:31:24 AM

I have tried different ports with no success. I haven't yet tried different cables; I happen to have a new cable shipping to me now which I'll try, but it feels like a long shot.
m
0
l
!