Sign in with
Sign up | Sign in
Your question

ASROCK X58 network cards stopped working

Last response: in Motherboards
Share
May 6, 2009 1:52:20 PM

I have the ASROCK X58 SUPERCOMPUTER 1366 and yesterday I rebooted my machine after a long period of not rebooting and when it came back up I had no internet. So I looked in the devices and it showed only one network card (Even though there are 2 on board) so I plugged the cable into the other one and the internet worked fine. So I was doing some stuff on the computer and had to reboot again..

When the machine came up I again had no internet and when I checked the devices I no longer had the 2nd on board card listed. :heink: 

So I decided to try to reinstall the drivers from the mobo disk but when I run the realtek drivers installer it stops and says I do not have any realtek (network card) hardware on this computer so it can't install the driver :fou: 

This is after a month or so of working fine..

My on board sound is still working fine and my USB as well.. So I take it my on board network cards decided to die????

Why the heck would that happen? It can't be normal.. Should I send the mobo back or just go out and get a NIC? at this point I'd rather just go buy a NIC but I don't know if this is a bad board that eventually it will burn out my sound and usb and everything else..

need opinions.

May 6, 2009 3:47:54 PM

is there a better place to ask this?
Anonymous
a b V Motherboard
June 19, 2009 7:22:20 AM

Sigh, i have the ASRock x58 deLuxe, and also my (1) Ethernet port died.. strangely enough a few days later my network card als got weird on me and soon after died.. Is there something wrong with ASRock boards?
I just can't bring myself to disassemble my whole system to return the mobo :-(
June 19, 2009 11:08:30 AM

Check the BIOS settings to confirm the crash hasn't somehow disabled the onboard NICs.
!