Sign in with
Sign up | Sign in
Your question

Problems with A-DATA SSD SATA2 disk connected to VIA EPIA PX10000g

Last response: in Storage
Share
June 16, 2010 4:36:13 PM

Hello,

I have a strange problem that my PX10000g does not seem to work with my SSD SATA2 disk (A-DATA S592 32GB). The disk is correctly recognized in BIOS as IDE master but if I try to install an OS (WinXP/Fedora/Ubuntu), it always fails during formatting or writing installation files.

Then, after further reboots, the disk is not found in Bios until I unplug and plug again disk's power chord. After that it is again recognized.

I used an old IDE drive and installed WinXP on it. Everything went fine with this drive. So I tried to format the sata drive from Win (just in case) but it failed as well.

But (!) the sata disk is working correctly with different mobo and it is also working with mine if I use sata->usb converter and plug it in an usb port.
It just does not work connected directly to sata port.

A possible cause could be that PX10000g supports only SATA1 disks and mine is SATA2 and it cannot downgrade (it hasn't got any jumpers). But I might be wrong with this. Also a weird thing is that VX700 chipset on the mobo supports SATA2 but mobo's manual says only SATA1 is supported.

Is there anything I can try?
Thanks in advance
June 16, 2010 7:45:41 PM

SOLVED:
Update of disk's firmware helped to solve the problem!:) 

Best regards
clime
December 22, 2010 9:37:32 PM

clime7 said:
SOLVED:
Update of disk's firmware helped to solve the problem!:) 

Best regards
clime


Hi clime I have looked in many places, but finally someone who has the exact same problem as i do..

my a-data s592 has fw 1571 and this exact behaviour..

the last time i tried to upgrade the fw resulted in a crash of my ssd. which was replaced by a-data..but not with the latest fw..
strange huh...

i do have to remove the powercord and then i starts... my system: msi x58 pro-e with core i7 / 920...
powersupply corsair HX850 gold.

hope to hear from you which fw did da trick for you and how u managed to do it!

Best regards, Pete!
March 29, 2011 8:26:36 PM

Sorry for so late response. I guess, you have already solved your problem but still...

I think the firmware that helped me was 1848.exe.
I followed exactly this howto: http://global.adata-group.com/downloadfile/1260326432_S...

I wasn't able to find this firmware at a-data websites. I guess the whole S592 series is outdated.
!