Built new pc, monitor doesnt come on

I built a new pc, everything powers up, fans all come on (gfx, cpu, psu)
Even the hard drive spins up
The CD drive opens and closes
I connected both power cables to the motherboard, connected the hard drive up, the gfx card and inserted the RAM
I then took out the RAM and got 4 long beeps...pause....4 long beeps (repeating)
Put the RAM back in and the beeps went away
I then removed the CMOS battery for 5 minutes, replaced it and still nothing.
I'm completley stumped seeing as I'm getting no beep error codes.
Do I have faulty hardware or am I missing something here? Please help :(

My spec is:

Gigabyte GA-MA69G-S3H - Motherboard
AMD Phenom X4 Quad Core 9550 - Processor
2 x 1GB Corsair DDR2 800Mhz - RAM
GeForce 9600 GT Dual DVI PCI-E - GFX Card
320GB SATA II Maxtor - Hard Drive

Help would be very much appreciated
5 answers Last reply
More about built monitor doesnt
  1. Sounds like you have a bad memory module. What happens when you test them one at a time?
  2. Try hooking your monitor to the motherboards vga out put.
    If succesful then go into bios and sed display priority.
  3. The memory doesn't seem to work alone
    Only in pairs, I get the 4 beeps when one stick is in
    I've also tried using the motherboards vga, and also tried a different monitor
    No POST, no beeps :(
  4. Yeah with the 6 pin power cord
    I took out the GFX card and tried the onboard VGA
    still nothing
  5. Each RAM module by itself generates the beeps?
Ask a new question

Read More

New Build Hard Drives Systems