Sign in with
Sign up | Sign in
Your question

2TB Seagate Hard Drive Not Detected in BIOS

Last response: in Storage
Share
June 20, 2010 6:31:34 AM

Hi guys,

This is my first time posting in any forum so any etiquette feedback is welcome :) 

I am building a brand new AMD powered machine with the following specs:

CPU: AMD AM3 X6 1055T 2.8Ghz Phenom II
M/B: ASUS M4A89GTD-PRO-USB 3 DDR3
RAM: G.Skill Ripjaws 1600 4gb (2 x 2gb)
HDD: Seagate SATA 2TB
DVD: Pioneer SATA

The problem I am having at the moment is that the hard drive is not being detected in BIOS whatsoever. Originally the dvd would show up but wasn't working properly but I had put the DVD drive in a SATA port that wouldn't support optical drives, Once I moved it to the optical port and that fixed that problem.

I've tried using the 6GB/s SATA cables and the 3GB/s cables and neither are working. I've tried all the ports (including the optical drive ones) and different power cables but nothing seems to work. I've tried tinkering with the BIOS but there doesn't seem to be an option other than AUTO detection.

I haven't been able to get my hands on an external floppy drive so the 'make-disk' option on the mobo driver disk isn't out of the question for a week or so....

The hard drive is brand new and works perfectly fine on my other system so I'm thoroughly confused...

Please help, I'm running out of ideas!
a b G Storage
June 20, 2010 7:44:54 AM

It seems you have tried everything without success, one more thing to try is jumper the drive back to 150 instead of the default 300. The 150 setting is a jumper across the 2 pins nearest the side of the housing.
Just out of curiosity, do you have another sata drive you can try to make sure it's not at the mobo end.
June 20, 2010 10:16:47 AM

yeah I just tried another hard drive and still no good. then flashed the bios and yep.... still no good.

I'm now in the process of looking for hdd drivers
a c 342 G Storage
June 21, 2010 3:02:38 AM

You have a new mobo which certainly supports at least SATA II, so don't worry about putting a jumper on pins to slow it down to original SATA 1.5 Gb/s. The drive works OK on another machine. But it will not work on this machine, and neither will another HDD. You've already tried swapping data cables. I assume you have connected power to it from the PSU, and then tried alternative power connectors.

There are only three things left. Which SATA ports are you trying to use? Should start with SATA_0 and / or SATA_1. Does this mobo have some SATA ports on the southbridge and a different group on a separate mobo controller? If so, make sure you are using the ports provided by the southbridge. Last possibility - mobo is bad and needs to be replaced under warranty. Call ASUS Tech Support or your parts retailer you bought from.
!