Sign in with
Sign up | Sign in
Your question

Asus Rampage 2 extreme

Last response: in Motherboards
Share
May 10, 2009 8:36:09 PM

Decided to build a computer for the first time and have hit a wall. I can't get the drivers from the motherboard disk to install. There are 6 installs and the only ones that worked are the ones that do not require a reboot. Except for the tweak it install which worked as well. Is there something I am missing or need to do first? Like I said never did this before so forgive me if it is something obvious.

I was taken to a screen that asked me to press 1-5 which would then ask to insert a diskette into the floppy. Well I don't have a diskette or a floppy.

The system is:
Asus Rampage 2 extreme mobo
Intel 920 cpu
Thermaltake 1200 toughpower PSU
2 EVGA Nvidia gtx 295's
WD 300GB Velociraptor
Corsair 2gb DDR3 x 3 ram
2 pioneer BD drives

I also loaded it with XP pro but can use Vista 64 as well if I needed. Any help would be appreciated so I can actually use the computer. Thank you!

More about : asus rampage extreme

May 11, 2009 4:47:53 AM

Oh, damn... I sure hope my build does not run into that. I have a similar build, very similar.
May 11, 2009 4:48:13 AM

just waiting for parts to come.
Related resources
May 11, 2009 8:24:49 AM

You are going to have to explain whats happening to the system as to why you think the drivers are not working. Does the system blue screen when you try to load the drivers? Does it just seem to hang on the reboot? Does the install program crash? Can you get your XP to load? Is XP a fresh install, and did you try to update to SP3 first? Usually you will need a floppy to flash your bios, not install drivers.

You can try a fresh install of the OS. I would use Vista on this system, as i dont think XP will even support ddr3 ram, and if it will work, im not sure XP will take advantage of the 3rd channel, nor is XP able to use the amount of ram you have. That OS is limited to 3gb of ram. Also XP can only use Direct X 9, where Vista can use DX10. You can also try to disable the floppy "legacy" drive from your bios, or change the boot order and put that floppy drive last in the list if you are not able to disable the device. (assuming your board drivers are in fact not on a 3.5 floppy) If you insist on using a hdd and OS installation from a previous setup, you can try to run the board driver installation program from safe mode. Im curious to see if your setup would work with XP sp3, if so, they maybe ill throw that back on my system, but as far as i know you would be limiting your setup using XP, if it is even possible to get it to work. Maybe install both OS, XP for your business, vista for your gaming? Anyhow, I have a very similar rig as you, same mobo, cpu, ram, and i had no problems, the only major difference is that i didnt attempt to put XP on my system as it isnt fully compatible with the hardware or it wont be able to fully take advantage of the hardware. Hope this helps you out.

Laters, Pain
May 11, 2009 6:12:38 PM

Thanks, I'll try the Vista and see what happens. XP has loaded but the bios updates from the disk aren't loading. Like I said I'll try the vista 64 and see.
a b V Motherboard
May 11, 2009 8:23:01 PM

You're saying it's the motherboard disk? Why not just download the drivers from Asus' website and run the setup files? If your LAN driver isn't loaded, you'd need a second computer and thumb drive to install the files.

May 12, 2009 6:35:42 PM

hamrhead,

the reson why your drivers are not loading is because you have the motherboard cd in the cd drive and its booting off of the motherboard cd everytime system reboots. to fix this, go to bios setup and go to boot>boot priority>hard drive as primary boot device. Hope this helps
May 12, 2009 8:49:20 PM

Okay, I installed the vista 64 and switched my boot priority to the hdd as it was set to the disk. Everything seems to work now. Thanks guys for helping out the noob! Like I said this was a first it turns out it was something simple. Thanks again.
!