Problem with my new Barracuda XT 2 TB

Just bought the new Seagate 2Tb SATA 3.0 drive. It shows up in my BIOS and device manager, albiet with only 4000MB of space, but not in my computer. I tried to format the drive, but it does not show up in disk manager either. According to Windows 7, the device is working properly and drivers are completely up to date.

I've tried switching around SATA ports, but that didn't help. I would try a different cable, but I really don't see how that would help in this particular situation.

Suggestions?

Thanks,

1st Duke.
4 answers Last reply
More about problem barracuda
  1. Hey 1st Duke, What motherboard are you using? Is it a SATA1 board? If so you will need to install a jumper to limit it's output to 1.5 Gbits.
  2. Gigabyte 890GPA-Ud3H with native USB 3.0 and SATA 3.0
    8 Gb DDr3 Ripjaws 1600 RAM
    Phenom II x6 @3.85 Ghz
  3. In Device Manager right click on it, see what options come up, if one is initiate click on it.
    I remember one time I had to initiate the drive first, but I couln't remember if it was Device Manager or Disk Manager.
  4. No option for initiate in Device Manager, and as I said, it's not detected in Disk Manager.
Ask a new question

Read More

Hard Drives Storage