Sign in with
Sign up | Sign in
Your question

GA-M750SLI-DS4 and Hyper-V

Last response: in Motherboards
Share
May 13, 2009 1:18:54 PM

Motherboard: GA-M750SLI-DS4 (rev. 1.0).
BIOS: F7 (Most current)
Processor: Phenom x4 9950 Black Edition
Memory: 8 Gigabytes OCZ
Operating System: Vista-64; Windows-7 RC

Problem: Hyper-V support has been completely unusable on my system. The processor supports it, and the board *should* support it according to Gigabyte technical support, but none of the utilities on my system will detect and utilize it.

I first noticed the problem back a couple months ago when I was using Virtual PC for a short while. I was never able to resolve the situation at that time, thinking it might just be an odd bug with Virtual PC in that it didn't recognize my Board/Processor properly.

Now with Windows 7's "XP Compatability Mode" and some extra resources I've found to test my computer (specifically an AMD Hyper-V testing tool I had initially overlooked) it seems the problem is NOT with the software like I originally suspected, but the problem is with the motherboard itself. Attached to the end of this forum post is the output I get from the AMD tool.

I've crawled over my BIOS with a fine-toothed comb trying to resolve the issue. I updated my BIOS a couple days ago from F6 to F7. I've turned on and off (and on again) the Virtualization Support in the BIOS numerous times, powering-down the system every time. I've loaded, "Optimized Defaults" and apart from pulling the battery on my motherboard (and in fact I might have tried that back a few months ago), and nothing has ever worked.

Gigabyte technical support has not been very helpful so far. As far as they know, the board should work as long as the Virtualization option is turned-on, but I don't know if the people I'm e-mailing actually understand Hyper-V or AMD-V.

Has anybody with this board managed to get Hyper-V support (and XP Compatability Mode) to work properly? Does anybody have any suggestions on anything I may have missed?



AMD Hyper-V Check Output
___
This system is not compatible with Hyper-V.
THis utility detected that a necessary BIOS patch is not installed
Please contact your system vendor to determine whether a BIOS upgrade is available.
If so, upgrade your BIOS and re-run the utility.
If not, consider upgrading to a new AMD64 system to get the latest in virtualization capabilities, performance and power efficiency.
AMD's most current processors do not require a BIOS patch to run Hyper-V.
This utility detected that AMD Virtualization (AMD-V) Technology is not enabled in BIOS.
Enable AMD-V in BIOS.
Re-run this utility to further verify your system is compatible with Hyper-V.

More about : m750sli ds4 hyper

June 3, 2009 10:03:18 AM

Dear HolyCrusader,
My name is Boban (bobant@beotel.net) and I probably wouldn't be of too much help for you and your problem, but just for your information I am using AMD Phenom X4 9550 processor (little less powerfull processor than yours) and Gigabyte MA78GM-US2H motherboard (I think that this is newer board than yours). AMD Hyper-V compatibility check reports positive answer that the system is compatible with Hyper-V, but after adding Hyper-V role and first restart system canot run anymore, till is Virtualisation enabled. Gigabyte was NOT of any help stating that it is desktop board not designed for W2k8 environment. Boards with Intel chipset Q45 or E45 were not also designed to be server boards but Hyper-V is running on them. If we suppose that processor is fully compatible with Hyper-V (???) it is obvious that BIOS is still not prepared and I am also not so sure the latest Hyper-V included in Microsoft W2k8 R2 installation is fully compatible with AMD hardware platform.
Related resources
Can't find your answer ? Ask !
June 3, 2009 5:14:18 PM

GA-MA78GM-UD2H also is totally unusable for Hyper-V.

This is Gigabyte slapping Microsoft and AMD's face.
June 5, 2009 6:18:06 PM

I see my topic has gotten new life, so I'll post my current progress with this problem:

According to Gitabyte, AMD-V and Hyper-V are supposed to work with my system, but it took about 2+ weeks of back-and-forth messages to Gigabyte before they have reluctantly admitted there might be a BIOS problem with the board. However, there is absolutely no ETA on when this problem might be fixed. I've heard nothing new from them in the last two weeks, and their website has no new BIOS's listed either.

During my exchanges with Gigabyte, I also sent in a message to AMD for any more information. I got a very fast and detailed response back from AMD that I found very informative.

Essentially, my current setup will (probably) support Hyper-V, but something in the BIOS is not permitting AMD-V to work. While some virtualization support might work with only Hyper-V, you don't get full hardware acceleration without AMD-V as well. In the case of the Windows 7 "XP Mode", it MUST have full AMD-V (or the Intel version) in order to even start. I remember Virtual PC 2007 had the same problem, and preliminary testing with VMWare on this box is also not working. I have NOT tried Server 2008 on the system, but I was never intending to run Server 2008 on this system anyway, so there's little point in loading it.

If I ever come up with any further information, I will post it here, but as of this point, the problem is yet to be resolved.
August 3, 2009 9:48:07 PM

I just got AMD-V to work. After days of agony researching and trying this and that, it has been up and stable for about 10 hours now. Here is what i did.

I have Server 2008 Enterprise with a GA-MA78GM-US2H motherboard with an AMD phenom II 4x 9600. The processor is Rev. 2 (if you have Rev 1 you are a goner get cpuid.). 8 GB of RAM. First I flashed the bios to 5 as was suggested in this thread because the GUI utility doesnt update to 5, restarted then went into Win2k8 and ran the check utility only to learn that the "R2 patch was still needed". So I tried it anyway. It Booted! Before all i got was the green line that suddenly stops at the start up screen. Then i gently started a VM and the whole thing crashed. Then I installed the Windows 7 video drivers for the Radeon 3200 and uninstalled the Desktop Experience feature. Reboot and here we are. The utility now says nothing about the patch but still says it wont work.

Please let me know if someone can replicate this.
!