Sign in with
Sign up | Sign in
Your question

Where did Catalyst 8.13 go?

Last response: in Graphics & Displays
Share
January 25, 2009 2:12:07 AM

So 8.12 came out just around Dec 11th 2008 and it brought us some nice improvements. Nvidia has gone as far as releasing a dual chip for 280 with new drivers. What about ATI? We're pretty close to Feb 2009 and so far no 8.13 yet... what's going on?

More about : catalyst

January 25, 2009 2:38:53 AM

murdoc said:
So 8.12 came out just around Dec 11th 2008 and it brought us some nice improvements. Nvidia has gone as far as releasing a dual chip for 280 with new drivers. What about ATI? We're pretty close to Feb 2009 and so far no 8.13 yet... what's going on?



It would be 9.1, and it's coming soon.
January 25, 2009 3:00:11 AM

yes. cat drivers are defined by (y).(MM)

eg 8.10 is 2008 and the tenth month (october)
Related resources
a b Î Nvidia
January 25, 2009 3:20:16 AM

I looked in the Catalyst history, and this (will be) the latest release in over a year. I worry that they ran into issues as this was supposed to be another miracle driver. Not to mention the holiday vacation in Dec./Jan. Hopefully all of this extra time will result in a much more stable driver (I heard some issues about 8.12, I just stayed with 8.11).
a b Î Nvidia
January 25, 2009 4:20:21 AM

Actually it's not year and month it's year.release , it just seems like month since they have a release schedule that usually is monthly.

Surprisingly long time for X.1 though, especially considering the issues with 8.12 , but fixing those may be the goal for the new release, the interesting thing will be if they can get it out by month's end or if 9.1 comes in Feb?
a b Î Nvidia
January 25, 2009 4:29:54 AM

EXT64 said:
I looked in the Catalyst history, and this (will be) the latest release in over a year. I worry that they ran into issues as this was supposed to be another miracle driver.


I don't think miracle drivers, but I think there's 4 stability issues, some random AA issues, and then also the mediocre/crap AVIVO converter output to address, alot of things to improve, hopefully they delay means they're ready to address more than just one issue, but that may be wishful thinking.
January 25, 2009 5:54:41 AM

ah ok.. that clears up a lot. I was looking at the pattern in which they release (usually within first 2 weeks of every month) and now we're hitting the 3rd week and still nothing yet so I'm getting a bit anxious :bounce: 
January 25, 2009 11:15:49 AM

TheGreatGrapeApe said:
I don't think miracle drivers, but I think there's 4 stability issues, some random AA issues, and then also the mediocre/crap AVIVO converter output to address, alot of things to improve, hopefully they delay means they're ready to address more than just one issue, but that may be wishful thinking.


Plus, improvements in crossfire! There is always room for improvement there.

I'm looking forward to Crysis crossfire gains! But so far it seems I'm aspiring for a distant utopia.
January 25, 2009 12:30:39 PM

Ive heard DX10 in quad opts are being done. They must be having problems, as I thought for sure theyd be out last week
January 25, 2009 1:07:19 PM

JAYDEEJOHN said:
Ive heard DX10 in quad opts are being done. They must be having problems, as I thought for sure theyd be out last week


DX10 in quad opts? Whats that?
January 25, 2009 1:11:43 PM

What I meant is, we should see quad optimisations in DX10 with these drivers, meaning better quad core threading
January 25, 2009 1:15:06 PM

JAYDEEJOHN said:
What I meant is, we should see quad optimisations in DX10 with these drivers, meaning better quad core threading


Ah! That would be awesome. I only recently upgraded to a quad core system.

Where did you get the quad optimisations news from?
January 25, 2009 1:19:23 PM

There was beta driver releases where a few sites did some benching on them, and other sources
January 26, 2009 5:29:20 PM

Last week of Jan now... No Drivers on ATI's site when I looked this morning.

Mayhaps they'll be 9.2?

Kind of annoyed, to be honest: Playing with 7 - It doesn't like the beta 8.12 drivers ATI say are supposed to work, and randomly hard locks when gaming. I was holding off on blowing it all out and going with a driver only install of 8.11 (which apparently work fine) on the idea that 9.1 should be out soon.

Ape - Thanks for the link to the beta drivers. I'll have a long think about using them.
January 26, 2009 5:35:48 PM

what GPU are u using scotteq?
January 26, 2009 7:00:58 PM

It should be this Wednesday, ATI confirmed there would be a 9.1, it's just running late.
January 26, 2009 7:15:09 PM

preyingrazor said:
what GPU are u using scotteq?



a 4870x2


I suspect it's an issue with Catalyst, moreso than the driver itself. No hard evidence, tho - Just what I think. What happens is it randomly hard Locks the computer while gaming, - might be 5 minutes, might be 5 hours - but I have to use the reset button to get it back. And, of course, when you have to do that you don't get a .dmp file to look at.

It's all on a separate drive from my main installation, and it's Beta software after all. And I dutifully reported what I know to MSFT.

It's not a big deal. Just a matter of what I'll do, and when.
January 26, 2009 8:19:55 PM

it could be due to overheating of the GPU too. are u overclocking it by any chance? Use some software that keeps logging ur GPU temperatures and then check the log file after a freeze and restart. If it consistently hangs up at or near the same temperature, then it's a heating problem.

Also try underclocking your card to see if that helps. The 4870x2 is a beast and won't mind a bit.
January 27, 2009 12:21:26 PM

:)  - I monitor the temps with Everest Ultimate, outputting to a gadget on my secondary monitor. With the fan set at 35%, they never exceed 70c, and the readings are consistent between 7 and Vista. So I can assure you that heat isn't the problem. Good suggestion though. :) 

For more detailia: My Win 7 install is on the exact same computer, running the exact same clocks, and the same type/series (Seagate 7200.11. No raid. Just a pair of HDDs) hard drive as Vista 64. The issue doesn't happen under Vista at all. And given that 7 is more... efficient would be a good word since they run roughly the same number of processes... it would be logical to presume Video stress should be a bit less if not equal. But Vista is stable, while 7 locks. From my own troubleshooting, I'm reasonably sure it's a driver/software issue. While I don't have a .dmp to examine for hard evidence, what I've found in Technet and elsewhere tends to confirm. (Stuff like a given game running fine in Windowed mode but not at all on full screen, or fine on one comp yet buggy on another, and other random weirdness. This is besides some Crossfire headaches, and the X2 is basically a crossfire card on one PCB, so...)


For sure, I'd be singing a completely different tune were it all presented as Production Ready, but like I said before - My primary install is on another hard disc. So it's not a big deal, just what happens when playing with Beta Drivers on a Beta OS. Take notes, send them plus whatever data you collect to Microsoft, and keep playing with it.


January 27, 2009 12:58:53 PM

Ah. I figured out your problem: beta OS and beta drivers :p 
January 28, 2009 6:27:30 PM

here it is wensday and still nothing
January 28, 2009 6:31:46 PM

Let's give them till Friday :p 

A 9.1 release seems bleaker and bleaker....
January 28, 2009 6:55:46 PM

at this rate it might be worth skipping 9.1 and going 9.2?
January 28, 2009 7:14:42 PM

That seems to be most likely. Or they might release 9.1 in the first week of feb and then rush 9.2 in the last week.
January 29, 2009 2:26:57 AM

seems a bit tight if they're going to rush it like that. In this case, I'm not expecting 9.2 to have much improvements over 9.1. I would think of it as "9.15" lol..

**EDIT**

I TAKE THAT BACK!! IT'S OUT!!! EVERYONE DOWNLOAD NOW!

http://game.amd.com/us-en/drivers_catalyst.aspx

**EDIT#2**

ok... well it's still listed as 8.12 on the actual downloads... I'm thinking it will be out tmr... check frequently guys!
January 29, 2009 5:39:03 AM

It's OUT! :D  Thanks a bunch Murdoc. I wouldn't have picked that up weren't it for you. Let's make this a regular thread. ;)  Cheeers!
a b Î Nvidia
January 29, 2009 5:51:41 AM

Still point to 8.12 (at the time of this writing) after you follow the original link.

Front page says 9.1, but takes you to the 8.12 driver packages.
January 29, 2009 6:17:05 AM

True. Keep updating guys.
January 29, 2009 12:31:06 PM

Although offical links aren't out yet, there are alternatives.

here's one


http://forums.guru3d.com/showthread.php?t=286359

Credits to Chipsy for the link.

**EDIT**
Some users from guru3d are talking about how the supposed new drivers didn't bring any performance increase. They're now suspecting that the drivers they've posted are in fact Candidate Releases so use them at your own risk.
January 29, 2009 1:14:49 PM

yeah, i just fixed a bunch of issues i was having with overclocking my system (CPU and memory) and crossfire with 8.12. I don't want to do it all over again for 9.1 (if I get the problem) so I'll wait for the final release.
January 29, 2009 1:55:04 PM

here's a look at GTA 4 Performance on 9.1 drivers during a 3 star cop chase.

Very stunning!!!

ATI 4870 1GB + E8400:

Settings:
26, 51,31, 5
Everything at high/very high rendering



Old driver performance:
Approx 20 fps.
January 29, 2009 1:57:04 PM

And now you're getting 7 fps? :p 
January 29, 2009 3:05:12 PM

alright so I got WS10 error shortly after and I reinstalled the game. I did another benchmark run and it's running at 29.99 fps on the settings of

View Distance: 25
Draw distance: 51
For got what this option was called: 31
For got what this option was called: 5

Everything is on very high or high depending on what I'm allowed to set.

I guess the game is more playable now =)
January 29, 2009 6:16:54 PM

The links are finally working.

game.amd.com
January 29, 2009 9:30:23 PM

Hmm.. for some reason the link isn't working on my firefox... not sure what the case is.. but yes the link is working on google chrome.

They've also taken notice that on 64bit drivers, AVIVO doesn't use stream to convert videos! Finally they've heard our cries!
January 29, 2009 9:53:40 PM

one word new catalist driver 9.1 i ad all the problems with windows xp .. then vista and allso windows. 7 the new driver came out doday and i am so glad.................. i have been working on the sound for 2 weeks and little sleep.. finaly... its working...
January 29, 2009 10:19:55 PM

ungrettir said:
i have been working on the sound for 2 weeks and little sleep.. finaly... its working...


haha. i like your dedication.
February 21, 2009 11:21:15 AM

Catalyst 9.2 released.
February 21, 2009 3:37:41 PM

preyingrazor said:
Catalyst 9.2 released.


Thanks for the update!! Great release! Crysis 20% increase and lots of fixes for vista regarding CCC :bounce: 

Here's an Alternative link if the official ATI link isn't up yet.
February 21, 2009 3:46:31 PM

yes indeed. i'll test the improvements in crysis and crysis warhead when i get back home!

Psyched!
March 21, 2009 6:49:54 PM

9.3 isn't worht the upgrade. It's mainly only 1 game which gets most performance increase.
May 19, 2009 8:49:27 PM

9.5 released. game.amd.com

read this first: http://www.tweaktown.com/articles/2764/ati_catalyst_9_5...

Performance drops are seen with most graphics cards. Especially the 4850. Not sure how crossfire is scaling yet though.

I'd recommend running a few benches with 9.4, installing 9.5, running the same benches and comparing the difference. If 9.5 performs poorly for you, too, then revert to 9.4.

It would be great if everyone shared the benches.
May 20, 2009 3:01:01 AM

I saw something weird though... 9.4 seem to give me occasional texture corruption in L4D but I haven't had issues like that since 9.5
!