Sign in with
Sign up | Sign in
Your question

SATA mystery when using SATA expansion card with 5850

Last response: in Storage
Share
June 25, 2010 1:51:37 PM

Here is a mystery I need help solving:

When I went to replace my 9400GT video card (on an ASUS P6T motherboard) with a Sapphire Toxic HD 5850 video card yesterday, I removed the 9400GT and installed the 5850. When I restarted my system my SATA HDDs were no longer recognized during pre-windows boot – messages said no boot drive found, insert bootable disk etc. (that is, it never got to the point seeing the drive’s boot sector).

So I pulled the 5850 and put the 9400GT back in and the drives are recognized and the system boots. So I am certain the drives are fine. I did this several times even trying using different 16-bit video slots – the same results. I have no shortage of power using Ultra X3 85W PSU – all connectors solid.

Now as background, the P6T has 6 SATA usable SATA ports for HDDs (the other two SATA Port 0 (E1 (orange and E2 (white) are Jmicron connectors that don’t seem to support bootable HDDs, so I don’t use them) save for maybe a CD-ROM drive on port 0).

I have a pair of Intel X25M G2 160GB SSDs plugged into the main SATA ports 1&2 (running as a RAID 0 array) to boot Win7 64) On SATA ports 3&4 I have a pair of WD 1TB drives in RAID0 running Vista 64. On SATA port 5 I have another WD 1TB drive not in RAID (back-up drive). On SATA port 6 I have a CD-RW drive (first of two CD-RW drives). That pretty much eats up my 6 primary SATA ports on the Southbridge.

Needing to support two more SATA drives, I added in an additional SATA adapter (an ASUS PCIE Gen2 SATA 6G adapter) that gave me two additional SATA ports on which I hung the second CDRW drive on one of those two additional ports.

Here is the weirdness: If I remove that SATA expansion card and install the 5850 video card, the HDDs ARE recognized and the system boots and operates fine. For some mysterious reason, having both the 5850 and the additional 2 port SATA adapter causes the SATA drives on the main Southbridge not to be recognized!

I checked the BIOS and the SATA configuration is properly set to RAID. When the 9400GT is installed, the drives are listed in the Boot order and in the HDD list; when I pull the 9400GT and drop in the 5850, the HDDs are no longer listed. I did this several times swapping them back and forth and making sure everything was properly seated and connected each time.

I’d really like to keep the additional SATA ports without having to upgrade the motherboard to one with more primary SATA ports on the main board.

Regards,
Mike
a b G Storage
June 25, 2010 4:10:04 PM

Have you tried installing the video card all the way, drivers and all, then install the SATA card? Have you tried different slots for the SATA card?
Did you remove the Nvidia drivers completely?
Sounds like you are having an IRQ conflict between the Vid card and SATA card.
m
0
l
June 25, 2010 5:35:28 PM

I did try various 16-bit card slots. I did completely remove all prior video drivers and the old card before installing the 5050. I did not yet try again after everything was fully installed (drivers and such) and rebooted with the 5850 fully functional - but I wonder if that will do any good since it never even got to find the boot drive let alone Windows to even get to the driver loading stage, but will tray again anyhow.

Yes, I also suspect its an IRQ conflict and I am not sure where in the P6T bios I can go rectify that if I can even get to it from there.

Regards,
Mike
m
0
l
June 26, 2010 2:09:05 AM

It appears that is was in fact an IRQ conflict. I had tried different slots for the 5850 but had not tried moving the SATA adapter..moving it to a different PCIe slot did the trick.

Thanks!
Mike
m
0
l
!