Sign in with
Sign up | Sign in
Your question
Solved

ASRock Super Computer - No USB HD support

Last response: in Motherboards
Share
May 14, 2009 6:04:34 AM

I have an external USB Harddrive (Western Digital My Passport 320gb) that works on a number of other systems except for the one I just built. I'm thinking it's a motherboard issue, although I am not sure. Any help would be appreciated, here at the stats:

ASRock Supercomputer X58
Intel Core i7 920
12GB OCZ DDR3 1600
NVidia GTX 275
Western Digital 1TB SATA HD
Lite-on 22x DVD-R
CM Stacker 830SE Case
Corsair 750W
Windows XP x64 (I have also tried with a LiveCD version of Ubuntu 8.10 x86 and 8.04 x64, same results)

Basically what happens when I plug it in is the lights blink for a second, then shut off. When the machine is booting and it is plugged in, I can hear the computer accessing the drive (although it makes the same sound a dead drive did that I used to have). A few people have suggested that I go into the Disk Management tool under Windows to check the drive, but neither that or my Device Manager sees the drive at all. Once again, thanks for any help.
a c 156 V Motherboard
May 14, 2009 7:48:11 AM

Where are you trying to plug the drive into? If you are using the case USB connectors, try using the motherboard connectors in back.
m
0
l
May 14, 2009 10:01:28 AM

Hey jsc, thanks for the reply. I tried that and the same thing happened. Just to note, I can plug other usb devices into any of the ports (including flash drives) and they all work just fine. It's almost as if there's not enough power getting out to power the harddrive, although I have no way of knowing/testing this theory(maybe theres a usb power tester out there?). Thanks though for the suggestion jsc, I'm open to any other ideas you may have.
m
0
l
Related resources

Best solution

a b V Motherboard
May 14, 2009 1:17:42 PM

some drives especially seagates are fussy with USB ports and sufficent power - i never really liked the 2.5'' usb powered drives

try getting a powered hub and use it for the hdd or make sure your PSU feeds sufficent power to the USB or similar rail etc
Share
May 14, 2009 5:22:22 PM

Hmm, tried hooking it to a powered hub (Belkin 7 port) and same thing happened. Tried plugging some other devices into the hub that work fine with this computer, and they were never detected. Tried the hub on another computer and it worked.
m
0
l
May 14, 2009 7:44:03 PM

Think I'm just going to accept that this is a dead mobo. Thanks for your input guys
m
0
l
October 1, 2009 1:44:41 AM

I have the x58, i7, 12gb corsair, and the 750 corsair power supply also, and have the same problem.

Actually i have the exact same system at work too, and have the same problem on both. I'm running Vista Ultimate x64 on both also. I tried the hard drive on a WinXP Pro x86 system (different hardware) and all is well.

I've had this problem with 2 different 320gb 2.5 external seagates and 5 different 160gb 2.5 external seagates.

I've come to the conclusion that they are conflicting with the motherboard. I've used seagates exclusively for about 10 years, love them, but these small externals with the x58 supercomputer motherboard just don't fly.


I hope my info can help,

x at digitallyoverwhelmed
m
0
l
October 1, 2009 7:58:44 PM

Yeah I'll probably stay away from ASRock, although I'd be interested to see if anyone else using a different company is having the same issue. It's not too big of a deal since I can just hook this up to an external usb dock for the power, just inconvenient.
m
0
l
April 8, 2010 10:00:06 PM

I have a asrock M3A790GXH mb and I have the same problem..

I have two 2.5 inch hdd drives, an samsung and a WD.

Is there any fix for this?!?

I tried to update the BIOS but it didn't mater.. :( 

regards
//rZn
m
0
l
April 9, 2010 2:33:04 AM

I'm not really sure what the problem is, but it seems like the board just doesn't supply enough power for external drives. Use a multi-port USB device (like this one) to supply power to them. Annoying I know, but that's what I've been doing to work around the problem. Maybe ASRock just sucks?
m
0
l
June 29, 2010 10:07:24 AM

Hi. I've got an ASRock M3A790GXH/128M and it won't power a toshiba 2.5" hard drive from the rear USB ports either.

Maybe ASRock limited the amount of power you could draw out of the USB ports for safety???

This drive does draw a lot of power, but it does work on every other PC I've tried it on, including laptops if you plug in both leads (it has the double-headed USB cable)

Or maybe they do just suck, like someone mentioned?

If someone could shed some light on this we'd be grateful
m
0
l
June 29, 2010 12:15:09 PM

I'm back after some more time wasting.

I took a multimeter and measured the voltage on pins 41,42 of the external USB hard drive when plugging it in.

The external drive is 2.5" Toshiba IDE, 60GB
Pin 41 is the 5V Logic line
Pin 42 is the 5V Power line.
These pins are supplied from the +5Volt power line which is present in every USB socket/plug.

On my drive these two pins are bridged together and therefore will be the same voltage. Upon 'plug in' the voltage at the drive pins drops as low as 4.45V on both pins. Then the drive cuts out, allowing the voltage to rise to 4.7V, whereupon the drive starts to spin up again, the voltage again falls to 4.45~4.5V causing the drive to cut out again ... and so on and so forth ...

This is on the rear USB ports of my Asrock M3A790GXH/128M. Plugging the drive in the front ports makes little difference, except that once the drive has cut out once the voltage on Pin41,42 rises to approx 4.7V and stays there, because the drive does not attempt to restart after one failed attempt.

The Asrock manual describes a jumper on the mainboard which you can move on header PS2_USB_PW1 from pins 2-3 (+5V standby) to pins 1-2 (+5V). The jumper on my mainboard came preset from the manufacturer on pins 2-3, though moving the jumper to pins 1-2 on PS2_USB_PW1 and retesting made no difference.

For what's it worth I retested on another PC I happen to have at the moment, coincidentally, which has an ASRock H55M Pro motherboard (Intel Core i3 530). The drive works perfectly on this PC!

Intrigued, I repeated the measurements. The voltage supply lines on the Toshiba 2.5" USB drive now only drop to 4.5V when the drive starts up. Once the drive has spun up the voltage stabilises at around 4.7~4.8 volts. You can probably see that there is hardly any difference, but the other board supplies just enough current and volts to prevent the drive from cutting out.

This is a cheaper board than the one I purchased. Both PC's have Antec 500W 'EarthWatt' power supplies and otherwise have modest video cards/power requirements.

Why would ASRock motherboards circa 2008-2009 not be able to supply enough power to the USB ports but later ones can? Answers on a postcard depicting Asrock's shameface ...


m
0
l
!