Sign-in / Sign-up
Your question

External Harddisk unable to to initialize in disk management

Tags:
  • Hard Drives
  • Western Digital
  • Disk Management
  • Storage
Last response: in Storage
June 26, 2010 5:05:36 AM

Hi
I have an WD External Hard disk model WD 1600...

Its showing in Device Manager but its not unable to read on any of my laptops. I tried to Initialize in disk management; it shows "Disk 1-- unknown-- Not Initialized--" I tried to initialize but couldn't do so.
I cant format the disk as I have very important data on it.
It shows in 'Safely remove Hardrive' at the task bar.

Please suggest me a solution for it. I need to restore the data on it. :(  :( 

Evy

More about : external harddisk unable initialize disk management

April 11, 2012 2:43:44 PM

hey, hope u still use this account and can see this, coz u posted this since 2009, anyways i have thesame problem as u, i have a new external harddrive toshiba, i started using it but then i mistakenly removed it without safe remove, nd now wont show in computer only in disk management, wont even initialise there, just want to know if u found a solution to ur problem, would really appreciate it, i know itz a long shot.
m
0
l
April 12, 2012 4:39:32 AM

Try this:
open device manager and find your external HDD.
delete or uninstall it.
Then go to Action>Scan for hardware changes.
This will scan your HDD(make sure its plugged in).
Hopefully it may solve the problem.
m
0
l
April 12, 2012 12:55:29 PM

i have tried it now, still thesame problem. tanx anyways. if u have any ideas i would like to try anything, coz this very frustrtin
m
0
l