Sign in with
Sign up | Sign in
Your question

Only one RAM stick will work at a time

Last response: in Memory
Share
May 19, 2009 2:00:19 AM

Hi, I just upgraded my computer with a lot of new stuff.

Upgrades are as follows:

CPU - E6600 -> Q9550
MB - Asus P5b Deluxe -> No Upgrade(Updated BIOS a few weeks ago)
RAM - 8GB Corsair XMS2 DDR2 800 -> 8GB G. Skill DDR2 800 (lower latency)
Video - 8800GT -> GTX 285
PSU - Thermaltake 440W -> Thermaltake 750W

Now when I tried to boot up for the first time after the upgrades, it freezes after "Initializing USB Devices"....First thing that pops into my head, remove all but one of the RAM sticks. Bingo, it boots right up. So I figure one of the sticks must be bad....Nope, no matter what combination I put them in, the PC will not boot if more than one stick is in. It will boot with one stick in any of the 4 slots, but not once a 2nd stick is introduced. I reset the BIOS to all default settings. The RAM says it uses 1.8-1.9 voltage. I tried it all, starting at 1.7 through 2.0. No difference.

2nd thought, maybe this RAM isn't compatible with my motherboard. I put my old RAM back in. SAME PROBLEM. Now only one stick will work at a time as well. This same RAM was working together less than 2 hours ago. What could have happened?

More about : ram stick work time

May 19, 2009 1:56:13 PM

*UPDATE*

I had some old CORSAIR XMS2 ram that I had bought with my original build....A couple of 512mb sticks. I decided to try them out for the hell of it. It worked with all 4 sticks...

The RAM that works together is:

Corsair XMS2 DDR2 800 (4-4-4-12)

The RAM that will not work together is:

Corsair XMS2 DDR2 800 (5-5-5-16)

-or-

G. Skill HK DDR2 800 (4-4-4-12)


I have tried every combination with the G. Skill RAM, and my previous working RAM, so unless 6 out of the 8 sticks are bad (impossible), it is not bad RAM.

BTW, if that sounds like I am trying to combine the G. Skill and the Corsair, I'm not.
Related resources
May 19, 2009 2:52:57 PM

Regardless, if the Corsair worked before the upgrades, and now it doesn't, that can't be a problem.
May 19, 2009 3:14:12 PM

Sorry; bad link...
May 19, 2009 3:46:20 PM

I updated the newest BETA Revision about 3 weeks ago in anticipation of my upgrades....I am at work, so I can not check the specific version, but I am 99.9% sure it is still the most recent revision.

That link sends me to a page telling me what BIOS supports which CPU? Not anything about system hangs.

And BTW, the PC reads "Initializing USB Devices", and then after that, it puts the amount of RAM I have installed, and that's when it freezes.
May 19, 2009 4:19:25 PM

Scroll down to the three Q9550 entries in the list and you will find that they require BIOS rev 1231, 1236, or 1238 depending on the specific processor. Click the "Go" button next to any of them and it takes you to the BIOS download/info page with the following info:

Quote:

Version 1238 2009/02/11 update

OS All
Description P5B Deluxe BIOS 1238
Fix system hangs at POST while using certain 4GB memory and CPUs.

File Size 834.85 (KBytes)


If you are running this BIOS, and still having problems, it would appear that the issue is not fully resolved, at least in regards to your specific CPU/memory combination.
May 19, 2009 4:31:15 PM

Hmmm, for some reason I believe I am using 1236....Maybe I didn't feel courageous enough to upgrade the most recent. I will check in about an hour when I get home and post again.
May 19, 2009 7:58:05 PM

By the way, what is the configuration of the ram which worked previously vs the new stuff? Section 2.4.2 of your motherboard's manual http://dlsvr.asus.com/pub/ASUS/mb/socket775/P5B Deluxe Wifi-AP/E2268_P5B_Deluxe.rar states no more than 2GB per slot...

If you are installing just two sticks, which slots are you using?
May 19, 2009 8:02:13 PM

It is 8gb total. 4 sticks of 2GB in each slot.

Both are 4 sticks total, equaling 8GB.
May 19, 2009 8:09:12 PM

Okay; just checking. :) 
May 19, 2009 9:44:11 PM

OK, that last BIOS update actually fixed it. I can't believe being one revision behind was the problem.

Thanks guys.
May 19, 2009 9:46:45 PM

Awesome!
!