Sign in with
Sign up | Sign in
Your question

External HD in Device Manager but not Disk Management

Last response: in Storage
Share
Anonymous
a b G Storage
June 29, 2010 10:42:49 PM

So I have this 1TB Western Digital external hard drive. I've had it for over a year now and it was working fine. I would swap it between my XBox 360 and the computer regularly. Then one day I brought it home, plugged it into the computer and nothing. My friend and I couldn't figure anything out. We went as far as to removing the hard drive and putting it directly into the computer. I considered it lost.

Then yesterday, on a whim, I tried plugging it back in to the USB port. It showed up in Device Manager but said its drivers weren't installed. I then switched USB ports on the back of the computer and magically it was there again. I had full access. Stupidly (and you can see where this is going) I didn't transfer anything off the hard drive right away. I was looking at a picture and listening to a song off said hard drive when the drive suddenly went unrecognized.

I can now see the drive in Device Manager both under Disk Drives and USB Devices. However it is not showing up in the Disk Management window. And yes, I checked both the upper and lower windows and it is not listed. Going to the area where you assign disk drive letters doesn't show it there either. Normally it is E:.

I also tried deleting the UpperFilters registry in regedit. There was no LowerFilters to delete. Obviously that didn't work either.

I've tried several cords and all my USB ports with no luck either.

I went to WD's website but they don't offer anything other than a partitioner which I'd rather save as a last resort as there are several things on the HD that I'd like to save.

So it's not like this is a new HD that needs to be partitioned or an old one that just crapped out. I know the data is there I just need to get at it long enough to get what I need. Maybe I missed my window but maybe I didn't. Maybe someone can help. I'm at my wit's end on this thing.
June 30, 2010 10:50:46 AM

Doesn't sound good to me, if it's a fairly modern drive it may well just be an SATA drive in an enclosure, as a last resort you might want to try disassembling the enclosure and seeing if you can connect the drive directly to an SATA port on your computer, that way if it's the USB controller part of the hdd that has gone wrong you should still at least be able to get your data back!
m
0
l
Related resources
!