Sign in with
Sign up | Sign in
Your question

PC that kills usb devices

Last response: in Motherboards
Share
May 19, 2009 7:00:27 AM

Hey guys, a customer of mine came to me with a pc that claimed to be not working with usb.
it had some other probs with HD partitions but that's not relevant imo.
tried it with their USB flash drives, their Digital Camera and PSP and i only get "USB device not recognized", "Unknown Device" and "No Driver Installed", that classic problem... you know what i mean.
my first diagnostic was "ok, your products are no good" so i tried it on other pc's and i get the same result.
tried with my USB drive, which i checked before and it used to work.
and after inserting it into their computer, my usb device started to get the same thing! on any pc!!!
and also with another flash drive i tried.

so conclusion is that this pc kills usb devices. tried to rescue them with no real solution.

any ideas what parts should i check?
Motherboard? PSU?

More about : kills usb devices

May 19, 2009 9:29:26 AM

I wonder, does it happen with the USB ports which are integral to the motherboard (on the rear panel), or only "front mounted" ports which are connected to the motherboard via internal cabling?

How old is this PC? Make/model? What operating system? If you go into Device Manager, are the USB devices marked with yellow exclamation icons?
a c 156 V Motherboard
May 19, 2009 12:24:56 PM

I bet that if you open the PC and look inside, you will find that the front panel USB headers are not plugged into the USB pins on the motherboard, but into either the serial or the firewire header.

They are all 9 pin headers looking like this - ::::.
Related resources
May 19, 2009 12:29:37 PM

Or, the front panel USB ports terminate in individual wires (as they do in many aftermarket cases) and someone accidentally or deliberately removed them from the header then got them mixed up when putting them back on.
June 4, 2011 3:02:23 AM

I have the same problem, with a computer I just built using the ASUS SABERTOOTH P67 <REV 3.0> same problem as above, accept that its only happening with the USB 3.0 slots on the motherboard(the back). The usb ports have already killed 3 external HD.
December 7, 2011 9:35:16 AM

My new (Oct 2011) Asus P8P67 DELUXE does the same thing. It destroyed a new Corsair USB 3.0 and a Lacie external USB 3.0 drive. On the Lacie I just assumed it was an interface problem and pulled out the SATA drive inside to install on another computer and it was dead. On the ASUS the USB ports on the motherboard destroyed the Lacie and the USB port on the front panel destroyed the Corsair.
!