Sign in with
Sign up | Sign in
Your question

IRQL_NOT_LESS_THAN_OR_EQUAL - USB Drive

Last response: in Storage
Share
July 2, 2010 8:59:54 PM

I've got a Maxtor portable USB drive that I use for back-ups, etc. It has worked fine on my XP SP3 machine for over a year.

Unfortunately, I experienced a very brief full power outage (just seconds) while the USB drive was connected.

Ever since then, when I connect the drive I get the blue screen with the above error. I've tried uninstalling the drivers for the drive and USB mass storage drivers, but still get the error.

I have taken the drive and plugged it in to another XP SP3 machine and it recognized it and worked just fine!

I'm sure that the power surge corrupted a file, but which one and how do I replace it?

Thanks.

More about : irql equal usb drive

a c 119 G Storage
July 3, 2010 1:17:47 AM

Connect the USB drive in the other computer, in which it works fine. Save all the files. Then do a complete format of the USB drive.

I hope you don't have the annoying U3 program on this USB. If you do, uninstall the U3.
m
0
l
July 3, 2010 1:23:17 PM

Thank you - that worked perfectly!
m
0
l
!