Sign in with
Sign up | Sign in
Your question

Help!! Accidently deleted C:\Users\public Major Problems ensued

Last response: in Windows 7
Share
September 13, 2011 10:05:07 PM

I recently deleted my public folder on accident, I have tried restoring it, recovery, creating a new User account, some fixes I found online that mess with the registry, and sfc scan, nothing has helped. I am unable to install some applications like Skype,when I try it tells me it cant access %PUBLIC%\Desktop. I cant edit most files, and whenever I create a new folder and name it i get a message that says Could not find this item, if I hit try again it works. Does anyone know what I need to do to fix this?

Your help is greatly appreciated
September 13, 2011 10:09:07 PM

What version of Windows are you using? Is the Public still there just not the contents or did you delete the public folder and contents?
a b $ Windows 7
September 13, 2011 10:13:41 PM

You could also take a windows disk and have it fix your system.
Related resources
September 13, 2011 10:14:55 PM

I deleted the Public folder, but tried restoring it with a previous version. I am currently using build 7601.

@ahnilated I will try that right now.
September 13, 2011 10:18:22 PM

Did the restore with previous version not go through or was there not an option?
September 13, 2011 10:30:51 PM

jcd1006 said:
Did the restore with previous version not go through or was there not an option?


The restore button was grey but I was able to drag and drop the old one
To no avail. I am currently trying system restore from the disk. Stupidly, I do not have a system image.
September 13, 2011 10:31:13 PM

1337dedrea said:
I recently deleted my public folder on accident, I have tried restoring it, recovery, creating a new User account, some fixes I found online that mess with the registry, and sfc scan, nothing has helped. I am unable to install some applications like Skype,when I try it tells me it cant access %PUBLIC%\Desktop. I cant edit most files, and whenever I create a new folder and name it i get a message that says Could not find this item, if I hit try again it works. Does anyone know what I need to do to fix this?

Your help is greatly appreciated


Can't hurt to ask. Did you look in your Recycle Bin? The folder will be there if you did nothing else but delete that folder.
September 13, 2011 10:42:15 PM

jamesm007 said:
Can't hurt to ask. Did you look in your Recycle Bin? The folder will be there if you did nothing else but delete that folder.


I completely removed it thinking it wasn't important :p 

I just remembered I had a backup from about a month ago and tried restoring the public file from there, but it did not help. I still am having the same problems.
I don't know if this is normal or not, but when i run set in cmd.exe PUBLIC is not in there at all.

and whenever I try to do a system restore from a restore point before I deleted the file I get an error on the restore, and it doesn't finish. This did not happen when I restored the public file from my backup though. Still though, I am having all the problems, I'm thinking I need to just completely reinstall windows over something so small :p 
!