Sign in with
Sign up | Sign in
Your question

USB devises are not recognized

Last response: in Components
Share
April 7, 2009 12:29:01 AM

Hi all,

I am a total noob when it comes to computer tech.
I am a just a regular personal computer user.

In my device manager, there is an yellow bubble beside "Standard Enhanced PCI to USB Host Controller"
and none of my usb ports are recognizing any devices.

Out of sheer curiosity, i disabled the driver with the yellow mark (Standard Enhanced PCI to USB Host Controller) and when i restarted my computer, all my USB devices are working.( Note that after restarting, the device status is still disabled and not updated ).

I could have continued using this way, except that i get a prompt saying my usb devices can run faster if i connect to USB2.0 ports. After a shallow search on google, i realised that i do have USB2.0 ports since my device manager mentions "Standard Enhanced PCI to USB Host Controller" ( having read in a thread ). So if my disabling that driver is preventing me from using the ports at full speed ( this am guessing ), i would like to do something about it rather than just let it remain disabled.

Can anyone please help me how to solve the problem?




to be more clear,

i have been having this problem for some time( An year and i even forgot when and why i started having this problem ). since then i have been using USB to PS2 coverters for my mouse and keyboard. And for pen drives and stuff, i was using the usb ports of my friend's computer who is connected to me through a LAN.

very recently i noticed that by disabling the "Standard Enhanced PCI to USB Host Controller" driver which was showing a yellow bubble beside it saying "This device cannot start. (Code 10)", my usb devices started to work, so that is how am using all my devices now.

More about : usb devises recognized

April 7, 2009 9:35:11 AM

Help guys
April 7, 2009 10:12:33 AM

Hi ashrogue, it's not really clear what you mean. You're saying that, once you disable the driver of your "Standard Enhanced PCI to USB Host Controller", your USB devices can connect properly, but not at USB 2.0 speed?

Would it be possible to get additional info from you? What computer are you using? Is it branded or something put together by a friend?
Related resources
April 7, 2009 1:15:54 PM

Hi manic,
My computer is a custom assembled one. it is a D101GGc motherboard.

and this is what is happening, my usb devices ( mouse, keyboard and pen drive ) stopped working, that was almost an year ago and i forgot when and why. May be i reinstalled windows XP then. But then, i got these USB-to-PS2 connecters and i started using my mouse and key board fine using the ps2 ports.since then none of my usb ports worked. If ever i had to transfer data, i sought a friend who connected to me through a LAN and i copied files from my computer to his and then i used his usb ports to get them into pen drive ( all of this is very tiring )

then i googled and found out about device manager and stuff, so when i checked my device manager, my "Standard Enhanced PCI to USB Host Controller" had a yellow bubble beside it and the status was "This device cannot start. (Code 10)".

i dint know what to do, i tried to update the driver ( the opetion was there in device manager ) and it still did not work, the yellow bubble was still there.

Recently i reinstalled windows XP again and immediatly after installation is complete my USB ports r working, as in i could use my mouse and keyboard ( both USB devices ) directly without any USB-to-PS2 connecters. But again after a few days, when i restarted my computer, suddenly neither my mouse or keyboard were working. So once again i had to use my USB-to-PS2 converters and when i checked the device driver, the yellow bubble was not there, it seemed the device driver updated itself on my restarting the computer.

So i got this idea and i restored my computer to a previous date and checked my device driver, now as before my "Standard Enhanced PCI to USB Host Controller" was showing the yellow bubble, so i immediately disabled it and removed my USB-to-PS2 convertes and my mouse and keyboard r functioning.

Since then, the device remained disabled like that, and my usb ports r working fine. But i get these prompts whenever i plug in a mass storage device ( pen drive ) that it can work faster if i plug into a USB-2.0 port.

so i checked on this site and in one of the threads it is mentioned that if ENHANCED is mentioned anywhere in the usb host controllers list, then i have usb2.0 fast ports.

so i am wondering, since i disabled this device "Standard Enhanced PCI to USB Host Controller", may be i am not able to get full speed.


so that is it. it is a long story i know, but computers r weird and like living beasts which know how to mess with people :|.

so please help me tame this daemon. Because i recently got an external HDD and i want to use it at full speed.
April 8, 2009 4:12:04 PM

Hi manic,

I must thank you first for trying to help me.
i hope the rest of the friends here would offer me their suggestions, please guys i am facing this problem since a long time.

from the link u provided, i gather that the usb drivers r in BIOS update?
so i downloaded the bios update and did as guided. my BIOS is updated.

My mouse and keyboard ( usb ones ) are working fine. Even my pendrive and external hard disk are connecting fine. But the prompt comes whenever i plug in these, that the device can perform faster if connected to USB2.0 ports.

So i checked the device manager and i still find the yellow bubble beside the "Stndard Enhanced PCI to USB Host Controller" saying code (10).

so, i am still having the same problem.

Please help me.
April 8, 2009 4:44:10 PM

and the transfer of a 700Mb file to external HDD is taking 20 minutes :|
April 9, 2009 11:28:26 AM

whatever i do, the yellow exclamation mark besides "standard enhanced pci to usb host controller" won't go. and my usb devices r functioning at usb1.1 speeds. work with External Hard disk is horrible now. takes infinite time.

I googled up and found that my problem is observed in microsoft products-duh :| check the link

http://support.microsoft.com/?scid=kb;en-us;312370


annoying that they din't offer a solution .

somebody help me please.
April 10, 2009 8:32:40 AM

Hi ash, sorry if I didn't get back to you right away. I might have given you the wrong link. Try out this URL:

http://www.intel.com/support/motherboards/desktop/d101g...

And click on "Latest Drivers". Download what matches your Windows version. I wanted you to update the drivers for your mobo.

I also assume you've tried your external hard disk on another computer? Was it able to reach USB 2.0 speeds? I just want to eliminate your hard disk as the cause of your problem.

In any case, I know your motherboard supports USB 2.0, since it's listed here plainly in the specs document: http://download.intel.com/support/motherboards/desktop/...

Let me know if installing the latest drivers for your motherboard fixes the problem. :) 
April 11, 2009 1:18:55 PM

Hi manic, The link you provided before also led me to this when i was searching for USB related drivers.
Most of the drivers there are Graphics related and a LAN driver. However there is one driver ( chipset driver something ). I did install it. I read somewhere that it effects functioning of other drivers?
Anyway, i restarted after installation is complete. But still same status, yellow mark and all my usb devices r working slow.

Also, i tried to download that particular driver "standard enhanced pci to usb host controller" which is showing error, but i couldn't download it. All websites redirect to microsoft which says i need version 7 or above Internet explorer ( which i have ) and it still refuses to let me download that driver.

and Yeah, I use my ext. HDD on my laptop, it works as fast as it can get(50 mbps ).Only my desktop is having this problem.

Tonight i plan to use my friend's hard disk to boot my mobo ( :p  ) very wild i know, but i want to see if the problem is a hardware related or a driver related.

i will tell u what i find.

gracias.
April 13, 2009 1:30:07 AM

Sorry I couldn't be of much help ashrogue, but since even a chipset driver update doesn't seem to work, it could be a hardware problem after all. Let us know what happens with your "wild" adventure :) 
April 13, 2009 2:19:30 PM

yesterday, i tried to boot from my friend's hard disk. But it is not recognized, i thought the disk is not compatible? am not very sure. But then i took my hard disk and tried to boot on my friend's mobo, it worked and when i checked his device manager, all the usb controllers r working fine and he was getting USB 2.0 speeds. One thing i observed is that a whole new set of host controllers appeared for him and none like mine. May be because his hardware is different?

anyway, so that is the status. i think the problem is with hardware and not any drivers. I guess i should contact a serviceman.

thanks for your help manic.
i will tell u if i solved it.
April 14, 2009 1:49:24 AM

Those new controllers are probably because of the new hardware, like you said. Ok, I also think your motherboard's at fault here. Keep us updated ash! :) 
!