Sign in with
Sign up | Sign in
Your question

Games crash in Vista 64 but not XP 32

Last response: in Systems
Share
January 10, 2009 7:00:26 PM

I'm having some weird problems I can't figure out. In Vista 64-bit Far Cry 2 and COD World at War will either crash or have a bunch of lines going all over the place. If I reinstall the graphic drivers and reboot one more time the game will just crash and no line go through the screen. However, if I reboot again there will be a bunch of lines going all over the place. And if i reinstall the graphics driver the game will just crash but no lines will appear. Half Life 2 will start but then it will freeze everytime. Half Life 2: episode 1 and 2 will play just fine. I reinstalled steam and the games. Same results. I reinstalled Vista, same results. I stress tested the CPU and Graphics card with Intel Test burn in, OCCT, Prime 95, ATI Tool, and rthbl or whatever it is called. Under Windows XP 32-bit everything runs fine.

Everything was fine up until one night when my water pump stopped working. I didn't notice it until the next morining. The computer stayed running the whole time, which is surprising. The liquid cooling is only cooling the processor.

My specs:
GA-X38-DQ6
Intel X3360-same as 9550 but lower Vcore
4870 X2- I used 8.10, 8.11, and 8.12 drivers all the same results
Vista 64-bit Home premium
Liquid cooling for processor only
Cooler Master 1000 W
G.Skill 8GB @ 6400

I switched out the processor with a x6800 and the same problem exists. I also reinstalled Vista 64 and no change in problems.

I am at a loss. And you're help would be much appreciated.

Thank you,

Fly2hip8

More about : games crash vista

January 10, 2009 7:29:12 PM

i have the same problem in vista x64 AND i have a 4870X2 as well. the problem is with ATIs driver. when you start the game and the driver tries to ramp up the fan speed, the whole system locks up.

to get around this, go into catalyst control center, enable ATI overdrive, and check manual fan control....just set the fan to something reasonable (i use 40-50% unless i plan on playing for a really extended period of time) and leave manual control on while you're playing. when you're done just uncheck the manual control box and you should be fine.

its annoying but its not that big a hassle and you'll actually be able to game.
!