Sign in with
Sign up | Sign in
Your question

Please help me! my SLI cards crash in Far Cry 2

Last response: in Graphics & Displays
Share
February 7, 2009 10:24:55 PM

Hello,
Is the first time i'm posting here, at this moment my pc problem has become very frustrating, so any help is going to be very appreciated.

I upgrade a week ago my video card from a evga Geforce 9800 GT 512 to a two (2) evga Geforce 9800 GTX+ 512 (512-p3-n884-ar) in SLI, since i did that, the only game i play (Far Cry2) crash continuously, i tried to play the game in ultra quality, with at :

1680x1050
AA 8x
V-Sync Yes
Bloom

The presentations and menu pages flow right but when began the game in the first 2 min, it crashes and a error windows mesage appear:

"the nv4_disp display driver has stopped working normally"

with the crash the video turn in to a mess (on windows) and its necessary to restart the pc.

I'm working with the 181.22 drivers for the geforce 9 series (the newest i think) and my pc is:

Quad Q9550 at 3.26 Ghz
4GB RAM
Asus P5N-D SLI NF750I motherboard
PSU CoolerMaster Real Power Pro 750W
HHDD Seagate Barracuda 320GB
Windows XP Pro 32 SP3
Aquagate max liquid cooling (in the box say 600w cooling solution, i don't know if this has anything to do with my problem)

Again, any help will be welcome
Fernando

More about : sli cards crash cry

February 8, 2009 4:52:51 AM

its a common problem with what seems to be all EVGA 9800 GTX+'s .. sorry dude.. doesnt look like theres much of a REAL fix.. go check the EVGA forums.
a c 271 U Graphics card
February 8, 2009 12:12:10 PM

Have you tried it without the OC on the CPU?, I have crashes if I run my 8400 @ 3.4 but @ 3.0 it runs rock solid stable.
Related resources
February 8, 2009 3:27:35 PM

Mousemonkey said:
Have you tried it without the OC on the CPU?, I have crashes if I run my 8400 @ 3.4 but @ 3.0 it runs rock solid stable.


Actually, the problem appear before OC the CPU... so, yesterday morning i formated the HHDD and make a fresh install... was in that moment when i OC the cpu.
February 8, 2009 3:35:46 PM

Thr video cards have two gold fingers, the problem happens when i use the gold fingers more close to the border of the cards (near the I/O connectors), but using the others (near the center) no crashes... but slowly performance, i think that ones are especially for the 3-way SLI.
What you think about this?
a c 271 U Graphics card
February 8, 2009 7:31:21 PM

I think I would try using both connectors at the same time.
!