Sign in with
Sign up | Sign in
Your question

UD4P MB LAN Issue with 64-bit Windows 7

Last response: in Motherboards
Share
June 3, 2009 3:42:10 AM

Just finished building a new rig today and I am trying to get everything setup. Installed every driver and got the bios set and everything checks out but for the life of me, I can't get the on-board LAN adapter to work.

I noticed that the drivers that come with the motherboard are for Vista and have been searching for Windows 7 compatible ones for a while now to no avail. I have tried just about every one on realtek's website and Gigabyte's doesn't even offer a LAN driver under Windows 7, only audio.

Sorry if this has been posted before, I am on a little netbook I use for school now and didn't find the search feature anywhere.

Anyway, doesn't anyone have a fix on the 64-bit Windows 7 LAN drivers for the UD4P Mobo?

My rig is:
i7 920
6 gig ddr3 dominators
Gigabyte UD4P
SLI GTX 285
300 gig velociraptor
Corsair TX850 PSU
SB X-FI Titanium

Thanks for the help in advance.
June 3, 2009 4:45:42 AM

Just shot off an e-mail to both Gigabyte and Realtek, hopefully they have some answers. Windows just keeps telling me over and over that there is no ethernet cable plugged in, when there is... Has anyone on these boards gotten the UD4P LAN adapter to work with Windows 7 (64-bit)?
June 9, 2009 2:22:31 AM

Odd that you're having problems. I put together almost the exact same system last week (except a GTX 275...I'm salivating for the 285 now that I think about it!), and I'm having ZERO problems with Windows 7 64-bit.

I downloaded the drivers from the installation disk.

I also flashed my bios? Have you done so, yet? You'll want to get the latest version from Gigabyte's website. I noticed people on Newegg said this helped them w/ your problem.

Worst case scenario buy one of those Killer network cards. :) 
Related resources
a c 177 V Motherboard
June 9, 2009 2:26:24 PM

I think that the mistake may have been 'loading' drivers; I've done numerous upgrades, since about build 6518, and did a 'fresh' install of both x86&x64 at the 'official' TechNet release of 7100 (RC1); I've a 'd' series board (DS5 - pretty much the same h'ware as yours) and the 'native' W7 drivers load perfectly, and work better. The included ATI video drivers actually work better than either the 9.4 or 9.5 releases of Catalyst; I load it anyway, as I use it to OC the GPUs, as well as 'manage' the Avivo codec - the Catalysts 'break' IE8 in win7: right clicking on a favorite crashes it - doesn't happen with the 'native' drivers. Also found I needed to load the audio manager - 'native', once again, works fine, but doesn't include the full feature set found in the actual manager...
a c 177 V Motherboard
June 10, 2009 12:23:21 AM

I rooted around in my update history - Win7 will install working drivers at installation, and then, first update, will put in:
Realtek - Network - Realtek RTL8168B/8111B Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)

Installation date: ‎5/‎9/‎2009 3:40 AM

Installation status: Successful

Update type: Optional

DriverUpdate: Realtek Network software update released in June, 2007

More information:
http://winqual.microsoft.com/support/?driverid=20067297

Seems to have none of the QOS problems evident in Vista or early win7 releases - probably improvements in the NDIS implementation, not the drivers...
June 10, 2009 6:30:00 PM

Bilbat, I'm having the same issue. I'm using a GA-MA790XT-UD4P mobo and I can't get LAN to work in Windows 7 either.

Realtek RTL8168B/811B Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)


a c 177 V Motherboard
June 10, 2009 8:13:39 PM

Acckk! I dunno what to tell everyone - I just installed it to a clean partition, sat back, and watched it run. First or second update, it did its thing, worked perfectly ever since! I'll tell 'ya what - I'll try to break it. Have a pair of f'ware upgrades to my router (one factory, one DD-WRT; I keep alternating to try to get everything right - so far - impossible), each time seems to lead to a batch of fiddling with all of it - including the LAN drivers - maybe I'll see somehing that looks related...
June 12, 2009 8:39:48 PM

I have the Gigabyte GA-MA790X-UD4P dual booting both XP and Win 7 64bit, each with it's own HD. Both work fine with the onboard GB LAN.

On the hard disk I installed Win 7 RC1, I installed the drivers included in the Gigabyte CD for the MB. Worked great, no problems.

Realtek RTL8168D/811D Family PCI-E Gigabit Ethernet NIC (NDIS 6.0)

In Win 7 Device Manager, it reports:

Driver Version: 7.2.1127.2008, 21/26/08 by microsoft

Hope this helps!
a c 177 V Motherboard
June 12, 2009 8:58:53 PM

Jeez, I might want to goose this thing once - I user the native 7 drivers, and let them auto-update, and I'm showing 6.195.625.2007 - going to online driver update says all up to date! But they work fine... I know they have a newer diagnostic util that works great, too - but it wants to install to the taskbar, so, this install, I avoided it (too much start-up junk the way it is!;=)
December 24, 2009 6:12:21 AM

hey, sorry to bump this late, but i got a p55-ud4p just the other day. i can plug a cable into it, and it doesn't even recognise it. Im running Win7 64bit, the full edition. Its not yet activated, because I can't get the internet to work.

I have 11days left, and im currently installing the latest drivers, to see how it works. @Bilbat, and anyone else, how do you suggest fixing it?

Do you think a wireless USB will help connect, or is there problems actually within the software. And is it Win7, or gigabyte's mobo?


MICK
!