Sign in with
Sign up | Sign in
Your question

X-Fi titanium fatality professional not recognized

Last response: in Components
Share
April 13, 2009 6:29:56 PM

I just installed the x-fi titanium fatality and tried to install drivers, but the installer says it can not find audio device. I looked in the device manager and its not listed in there, just unknown device. Uninstalled all drivers and tried to reinstall again but same thing. Also tried a different pci-e slot but it does the same thing. Im running a dual boot of Vista 64 and Windows XP but both Os's get the same error. The card does light up in the case when i power up. Thinking it might be a faulty card, unless i did something wrong?



Asus x48 Ramapge Formula
Q9450
OCZ reaper 4gig
Corsair 750watt
VisionTek HD3870 512
April 15, 2009 3:38:15 AM

Sent it back, must be faulty. Thanks for the help........YEAH RIGHT
September 15, 2009 3:21:00 AM

Dude,

I wen't nuts trying to fix this. I had the same problem. Won't dectect the card, card won't start error 10, etc, etc, etc, tried everything I found on the forums, nothing worked. If one more person told me to switch slots I was going to go mad. I thought I had a dead card.

THEN....

I found a post that suggested the contact pins on the PCI card can oxidize and not connect properly. They instructed me to take a soft eraser and rub the contacts clean. I gave it a good rub, and guess what... no more problems. Card detected properly both in BIOS and Windows. Installed the driver from the CD, it found the card, no more issues.

Try it. Let me know if it works for you.
!