Sign in with
Sign up | Sign in
Your question

4GB usable out of 6GB installed, rest is hardware reserved

Last response: in Motherboards
Share
June 7, 2009 2:10:54 PM

I'm on a gigabyte x58 UD5 with windows 7 64bit. after the fresh install i could see all 6GB in task manager but just recently i noticed only 4GB is showing up while 2GB is shown as 'reserved for hardware'.

I have turned off hypermemory in atitraytools as i have a HD 3650 with hypermemory. but its still showing 2GB reserved for hardware.

Is there anyway to fix this without a complete reinstall?

im definitely on 64bit OS, i dont have memory mapping in my motherboard bios(F5) and i have turned off hypermemory as i mentioned before.
October 30, 2011 7:22:32 PM

Macpod said:
I'm on a gigabyte x58 UD5 with windows 7 64bit. after the fresh install i could see all 6GB in task manager but just recently i noticed only 4GB is showing up while 2GB is shown as 'reserved for hardware'.

I have turned off hypermemory in atitraytools as i have a HD 3650 with hypermemory. but its still showing 2GB reserved for hardware.

Is there anyway to fix this without a complete reinstall?

im definitely on 64bit OS, i dont have memory mapping in my motherboard bios(F5) and i have turned off hypermemory as i mentioned before.



Well this is a very common problem, so before you go replacing dimms or buying a new cpu (if you think your memory controller is bad), do this:

1: go to start>run (search for "run" in vista/win7)> then type "msconfig" in run (without quotes)
2: go to the boot tab and click advanced options. Make sure the maximum memory checkbox is unchecked. If it is checked, Un-check the box and hit ok, then hit apply, and then hit ok and restart your system.
3: make sure you have the latest BIOS, if you do not, you can go to your motherboard manufacturers' website and find it in the support/drivers section.
If your BIOS is up to date skip to step 8.
4: Download the BIOS and burn it to a CD or Flash Drive.
5: restart the computer and insert the CD or flash drive you added the BIOS image on
6: set ALL BIOS SETTINGS to DEFAULT!
6: go into the boot settings right on the startup using the hotkey specified on startup, and change the first boot device to CD/DVD drive or USB (depending on what you used to store the BIOS image).
7: Flash the BIOS, set the settings back to normal and restart the computer. Usually the manufacturer of the motherboard will have their own BIOS flash procedures on the website and/or included in the BIOS image download.
8: Restart the computer and go into the BIOS settings.
9: Go into the memory options and go to TRL (this setting may be in the memory timings section of the options), and change the value to +2. This allows for the DIMMS to be initialized/detected before the handoff to the OS!
10: While in memory options set the CHSTRAP or MCHSTRAP to "DRAM RATIO"
11: Go into the voltage settings and set the RAM voltage to a supported value. Check on the box the modules came in or check with the manufacturer before you do this, as setting the voltage higher than the supported value could damage the DIMMS and/or void the warranty.
12: Save the settings (usually by hitting F10) and restart.


That should fix any memory initialization/detection issues. If this does not fix your issue. Run memtest86 to see if one of the DIMMs/slots is bad. If all comes back ok and you still have problems, there could be a slight chance, that for some reason, your memory controller inside the CPU is on the fritz, meaning you may have pushed memory and/or CPU clocks and/or voltages too far, and you may need a new CPU. However, that is rarely the case. Hope this helps!
!