Sign in with
Sign up | Sign in
Your question

My Intel Core 2 Duo E7400 is only running at 50%

Last response: in CPUs
Share
April 15, 2009 12:59:20 PM

Hey, Ive recently purchased a brand new Intel Core 2 Duo E7400 and when I played AOE3, My Nvidia Monitor says that i'm only using 50%. Ive had a look around and some people say its to do with hyper threading, but dont tell me what to do, your help is really appreciated.

System Specs:

- Abit IX48 GT3
- Intel Core 2 Duo E7400 2.8 GHz
- 2 GB Kingston DDR3 1333 Mhz
- WD 250 GB HDD 16 Mb
- Gigabyte 8600 GT 512 DDR2

Cheers,

Stefan
April 15, 2009 2:33:58 PM

If I'm not wrong, Age of Empires is not really demanding. I mean, it needs a 1.4 GHz single core, 256 MB of RAM and a 64MB video card. Test it with 3D Mark 06/Vantage and see what load you get.
m
0
l
April 15, 2009 2:52:40 PM

rags_20 said:
If I'm not wrong, Age of Empires is not really demanding. I mean, it needs a 1.4 GHz single core, 256 MB of RAM and a 64MB video card. Test it with 3D Mark 06/Vantage and see what load you get.


What do you mean load? I cant get my 3D Mark score coz I can't currently get access to the internet (my wireless card wont install the drivers properly)

As you say I should be able to run AOE 3 max settings, but when I used the Nvidia monitor and turned on logging it said I only get a max of 50%
m
0
l
Related resources
April 15, 2009 2:54:33 PM

I don't understand. 50% of what? Isn't it your CPU load?
m
0
l
April 15, 2009 2:57:16 PM

Try a more demanding game, AOE3 won't need to use all of your processor. Either do what rags said, use a benchmark program(3Dmark) or download a newer game demo and try it out.
m
0
l
April 15, 2009 3:15:18 PM

go into bios and apply default optimized settings then choose your preferences .. save, reboot
m
0
l
a b à CPUs
April 15, 2009 3:28:45 PM

Start prime 95 and watch you cpu go to 100%

Having it at 50% on a game is good, if it was 100% you would lag. If it went to 100% during game it would be a bottleneck.
m
0
l
April 15, 2009 3:52:41 PM

rags_20 said:
I don't understand. 50% of what? Isn't it your CPU load?


Yeah it is, but the odd thing is it doesnt change it just sits at 50%, 51% 49% that general area, and in a game youd thing that some parks ate more CPU intensive than others, say when there is more AI or more processes stuff like that
m
0
l
April 15, 2009 4:46:13 PM

We're talking Age of Empires, not Crysis or something like that. Do as daship suggests.
m
0
l
April 15, 2009 5:17:46 PM

Does it really matter what CPU usage you're seeing as long as the game's running properly?
m
0
l
a b à CPUs
April 15, 2009 6:17:28 PM

That means it is single threaded - it is running one core at full load, but it doesn't support dual threads. It's normal.
m
0
l
April 15, 2009 6:52:58 PM

Play Crysis and see what happens. You should use about 90% or higher.
m
0
l
a c 83 à CPUs
April 15, 2009 9:17:08 PM

It's at 50% because the game is single threaded and you have a dual core processor. Your only using 1 of your two cores, 1/2 is 50%
m
0
l
!