System restore isnt working

Hello,
I have a serious problem with my system restore.Every time I try to use it it gives me an error like this:http://imageshack.us/photo/my-images/535/erroryg.png/
And when i tried to turn it on from the My Computer attributes from start menu it only shows me this:http://imageshack.us/photo/my-images/685/errornc.png/
And when i go to Start menu>Run>services.msc>System Restore Service and try to start it,it gives me an error likes this:http://imageshack.us/photo/my-images/20/errrore.png/
And i found the rstrui.exe file in my computer finally and when i double click on it it tells me:System restore is turned off
Would you like to turn the System restore on?
and when i click ''yes'' it opens the control panel and nothing else will happen...
I hope that some1 can help me because i really know nothing about computers...
2 answers Last reply
More about system restore isnt working
  1. I would run a malware/anti-virus on entire HD as it seems your system function is hijacked by that website. Get ccleaner (filehippo.com) and run the registry cleaner after virus was deleted. Clean all temp folders including Documents & Settings on all the users you have installed. Then try and restart service again. If that fails from file corrupt or missing, get the install CD for windows, go to Start-Run- type sfc /scannow, should repair and add system missing files deleted or damaged by virus.
Ask a new question

Read More

Start Menu System Restore Computers Windows XP