Sign in with
Sign up | Sign in
Your question

Mobo wont recognize HDD...

Last response: in Motherboards
Share
June 12, 2009 3:33:37 AM

Okay so let me begin by saying that i originally had: gigabyte p35 dsl mobo with my dvd drive + 40 gb Maxtor hdd connected together on an IDE cable with the dvd drive on the farthest connector as a slave. So, there is only one IDE slot on the mobo and I wanted to add another hdd (200 gb western digital). I plugged in a PCI card with 2x IDE adapter slots and plugged the new 200gb hdd to the end of an IDE cable attached to the adapter card. The computer started up and told me to press 'F3' to enter raid options but my keyboard was unresponsive. After several more tries with similar results I attempted to switch around the cables, trying the dvd drive on the adapter card with both hdd's on the same IDE cable etc. The weird thing here was my mobo DID recognize that i had a 200gb western digital but NOT my original hdd. So, realizing that this was a failure, i took the PCI card and new 200 gb hdd out and put everything back to how it originally was. I start my comp up and get an error: failed to boot off of disk drive, please enter cd/dvd rom. I check the BIOS and the only thing being recognized is my dvd drive as a slave on the IDE channel 4. I check my voltages and all is fine, so I am pretty sure the hdd is being powered. I tried replacing the IDE cable, the power plugs I used, changing the jumper settings, but to no avail my hdd won't work! I even tried putting the new hdd in place of my old one and my mobo won't recognize that either. I am really stumped and I want my comp back, thanks in advance for any tips or advice.
June 12, 2009 10:58:41 AM

dys

I can suggest a few trys for you. But is sounds like the BIOS may have been changed somehow. Confirm the BIOS settings for 1) boot up sequence (drives in what order) then 2) what types of drives are recognized as bootable.

You may need to install ONLY the old 40gig HD with nothing else to get the PC back up running. If/when that happens, you can add the DVD and PCI card back in - one at a time.

The question is - initially when you put in the PCI card - did you just install it and load the driver for it BEFORE you attached the 200gig HD? If not, you should have.

If the BIOS settings are correct and you still cannot see the HD as a bootable drive, then the drive MAY have become corrupt (not sure how) and you know what that means....

perhaps this might help...

Good luck
a b V Motherboard
June 12, 2009 2:34:56 PM

If the PCI IDE card is in the computer, it will always try to boot from that.
If you installed the driver for the PCI IDE card, you should attach it only to the PCI IDE card.
Related resources
June 12, 2009 3:27:48 PM

I did not install any drivers for the PCI card prior to putting it in. I already tried putting only the 40 gig by itself on an IDE cable. The boot-up sequence is: hard disk, floppy, hard disk. The only options for hard disks is "Bootable Add-In Cards".
a c 177 V Motherboard
June 12, 2009 3:31:27 PM

Please post manufacturer and part # or name for the IDE card - will try to find some documentation to advise...
June 12, 2009 3:45:29 PM

I don't have the box for it but it is a Silicon Image brand. It is this card right here: http://www.shop4tech.com/item6066.html but the main problem is that my original setup doesn't work.
a c 177 V Motherboard
June 12, 2009 4:43:21 PM

Hmmm... Not so easy a task; Silicon Image is actually 'Sabrent', and their home page has a 'broken' flash sequence on it that dumps you to an empty screen - not too reassuring! After dinking around with FireFox, Safari, Chrome, 64 and 32 bit IE, and 'compatibility mode', I finally captured the home page code, and decifered that your product page is here:
http://www.sabrent.com/#itemID=0&section=Drivers&itemNa...
The manual says:
"BIOS Setup
If you already have a bootable hard disk connected to the mainboard’s IDE controller but want to use the hard
disk connect to the Ultra ATA/133 IDE RAID controller card as default bootable drive (Drive C). You need to
set the mainboard‘s BIOS to boot SCSI first. Please refer to the mainboard’s user manual for more details." Odd...

From the odd syntax of the manual, I'm betting it was (poorly) translated from Mandarin - again, not too reassuring... The manual also mentions using 'their' cable, but nowhere that I can find does it mention the type of cable that it is, or anything about requisite drive jumpering. From the wording, I'd venture a wild guess that it's 'cable select', and needs the drives corresponingly jumpered.

Another guess about the 'unresponsive' keyboard - likely the 'chunk' of software that manages the thing doesn't recognize USB keyboards. While Intel is trying to lead the charge to drop PS2 ports on motherboards, there is still stuff floating around suffering from this problem - one example is the 'boot-time defrag' in Diskeeper - if you want to control it, you need to plug in a PS2 keyboard; you don't see this problem in windoze, because the hardware abstraction layer handles it; but at boot, the app must handle 'raw' USB input, or it's dead to the world...

I think evongugg may be onto something - I'd try it with all the IDEs hooked up to the card only, and see if that cures it...

My primary thought looking at this is 'why?' Once you add the price of the card and the drive, you could have a nice SATA drive, and no headaches; NewEgg today is advertising 1Tb Seagate 'greens' for $70!
June 12, 2009 5:01:53 PM

The 200 gb is an old one my bro had, and this way i'd lose all the data from my old hard drive too, and it's not guaranteed the hard drive is the problem.
a c 177 V Motherboard
June 12, 2009 5:22:30 PM

Yeah, one way or another, I think it's the culprit - Sabrent looks like one of these Taiwanese 'silicon foundries' that make a lot of assorted ancillary add-on cards, and sort of lets the support fall by the way-side; cheap enough stuff so no one will make a big stink about problems... If it's still at the stage where you can RMA it back to the vendor, that's what I'd do - and the IDE drive, too - see if you can get a 'store credit' deal, and use it to buy a SATA drive - it'll be faster, and trouble-free, for the most part... My main reservation about such devices is based not on the devices themselves, but the drivers. God knows, there are plenty of problems to go around with well-known manufacturers like Intel & jMicron, who actually work at keeping their drivers functional and up-to-date; who needs something running in ring0, where it can do a lot of damage, that's hacked together by amateurs? The equivalent to your 200G IDE, in SATA, is listed at NewEgg for $40.00; I would think it'd be worth that to just "make the problems go away!"

http://www.newegg.com/Product/ProductList.aspx?Submit=E...
June 12, 2009 5:32:43 PM

Meh but the 200gb is an old one my bro had, and it is not guaranteed that the SATA hd will work as I don't know if it's an error with the hard drive or mobo. and i'd lose all the data from my old hd :( 
June 14, 2009 12:15:14 AM

well i ordered a 500 gig sata, but how do igo about recovering the data from my old hard drive?
a c 177 V Motherboard
June 14, 2009 12:54:34 AM

You should be able to install the OS to the SATA from the IDE ODD, and then mount one IDE HDD at a time, to xfer the old data; do the small one first, and finish with the large one - then you can leave it in for backup purposes. You don't want to xfer the old OS from the original drive - you're better off with a fresh install.
June 14, 2009 1:04:01 AM

Hm, what do you mean install the OS from my IDE, can't i just use my windows xp cd?
a c 177 V Motherboard
June 14, 2009 2:31:34 AM

"You should be able to install the OS to the SATA from the IDE OpticalDiskDrive"...
June 14, 2009 4:51:22 AM

oh dur sorry, and thanks btw for helping me along this
a c 177 V Motherboard
June 14, 2009 3:56:57 PM

Alway welcome! By the way, if you want a rush, DL and install Win7 - I can pretty much guarantee you'll never go back, and it's really good at hardware...
!