Sign in with
Sign up | Sign in
Your question

Problem with Dlink DWL G520

Last response: in Components
Share
April 18, 2009 3:32:24 AM

So, I have this Atheros chipset dlink card. It works just fine in my other OEM Dell computer on Windows XP. But there is a problem when I put it into my new custom built computer that no matter what OS (be it Knoppix, Ubuntu, Opensuse, Linuxmint, Windows 7, Windows Vista, or Windows XP) I can either trick it into booting (by going into safemode and disable it then once inside regular mode enabling it, or by turning off PCI detection on linux flavors) but alas those options let me boot but don't let the card work. One of the reasons I upgraded from stock PSU to the Corsair VX450 was for the 8 pin 12v EPS connector that I thought would make the card work. I have tried disabling all of my onboard devices via the bios and even underclocked my entire Computer just for good measure. I have also tried a different video card (XFX 8600 GT) and every other PCI slot I have and it still doesn't work!! I think that this motherboard might be the culprit but I would like another opinion other than my own. Here are my specs:

Corsair vx450
Asus P5Q motherboard
3 GB Crucial 667 memory in dual channel (@ 986 MHz on stock voltage)
e5200 CPU (@ 3.8 GHZ with 1.368 volts)
Sapphire 4830 with bios volt mod
500 GB HD (don't know the brand name off hand)

Any help would be greatly appreciated.

More about : problem dlink dwl g520

April 18, 2009 7:06:31 PM

Can anybody give me a suggestion to try? I feel like there might be conflicting devices but I'm not sure how to fix it. I tried another PCI NIC and it doesn't work also...
!