Sign in with
Sign up | Sign in
Your question

Bad Memory Socket(s) on GA-MA790X-UD4P?

Last response: in Motherboards
Share
June 13, 2009 5:08:12 PM

Having problem with getting my system to boot with my match ram sticks in paired slots for dual channel.

So I just built the system this last week and for reference the specs are:
(Everything at stock settings)
AMD Phenom II X4 940 (stock cooling)
SAPPHIRE Radeon HD 4870 1GB
Antec 900
G.SKILL 4GB (2 X 2GB) 240-Pin DDR2 SDRAM 1066
CORASAIR 750W
WD Black 640GB
GIGABYTE GA-MA790X-UD4P

If I have both sticks of ram plugged in slots DDR2_1 & DDR2_2 (which are color matched for dual channel) and when I power on the system I get LEDs and Fans but nothing on the monitor at all.

So here's the break down:
If I boot with both stick in slots 1 &2, blank screen
If I boot with just one stick in slot 1, boots fine, 2gigs
If I boot with both sticks in slots 1 & 3, boots fine, 4gigs single channel
If I boot with both sticks in slots 3 & 4, blank screen
If I boot with one stick in slot 2 or one stick in slot 4, blank screen

Is there a bios setting I need to know about? I went ahead and reset the cmos by popping the battery for five minutes.

Are my 2 & 4 memory sockets bad? and I need to just RMA my mobo back to newegg?
a b V Motherboard
June 13, 2009 5:42:50 PM

Hi R

Have you tried setting the mem voltage & timing manually in the bios to manufactures recommendation?
a c 177 V Motherboard
June 13, 2009 10:16:25 PM

By default, the "DCTs Mode" item, on the "DRAM Configuration" portion of the "MB Intelligent Tweaker(M.I.T.)" page of the BIOS is set to "Unganged", which sets memory control mode to single-channel; you want to change it to "Ganged", which will activate dual-channel mode...
Related resources
June 14, 2009 12:32:44 PM

bilbat said:
By default, the "DCTs Mode" item, on the "DRAM Configuration" portion of the "MB Intelligent Tweaker(M.I.T.)" page of the BIOS is set to "Unganged", which sets memory control mode to single-channel; you want to change it to "Ganged", which will activate dual-channel mode...


How in the world did you find out something like that? Do you own this motherboard? :o 

(or is it just google...)
a c 177 V Motherboard
June 14, 2009 3:46:54 PM

Nah - I've got seventy or so GB manuals DL'd here; first thing I do when somebody has a problem is zip through it - wonders what a person finds! If it's one I don't have stored, the first thing I do is add it to the collection. For the Intel 'd' series boards, the BIOS are all pretty much the same, so I often know where to go; but, I 'don't do' AMDs - so I've got to hunt. Slowly but surely, though, I'm starting to get a handle on them, too... I also am pretty useless, so far, re i7 pieces; but, I'm trying hard to get up to speed: by the time the 35nm steppings are introduced toward the end of the year, I figure the memory makers will have the new tri-channel stuff licked, and the BIOS writers will have the (I think approaching eighty - certainly no worse than, say, the Q9xxx's, but new) i7 errata all compensated for - and it'll be time to try one.

http://www.sevenforums.com/68978-post410.html
a b V Motherboard
June 14, 2009 4:45:59 PM

+1 for bilbat, good job!
a c 177 V Motherboard
June 14, 2009 5:40:15 PM

Thanks, I try... I have to point out that I aim for 'searchable' write-ups; I have my own disasters, too, and the net is really amazing! The other night, I needed to do a router flash, and it got 'bricked' - no comms for network to find solution, half of TV channels bolixed (use a networked SiliconDust HD_HomeRun for ATSC & ClearQAM), no support phone number in Cisco manual (which I had taken the time to print out, in advance of problems), back to 'sneaker-net'! Finally got machine closest to cable modem on-line, and found a six year old post, for a router that no longer even exists, that gave me the solution: f'ware could be TFTP'd, but would only work if you 'hit' the router during the first few seconds after a power-up; included utility did TFTP - but the trick was, it would do three re-tries; ran back & forth five times - 'triggering' the load, & run to other room to power up router; fifth time, it 'caught', flashed the f'ware, saved the day (well, night)! Took about four different sets of search terms to find this little tidbit, but it was still accessible after all this time - a pure-D lifesaver!
June 14, 2009 9:55:09 PM

Thanks for the advice bilbat, but no go. I restarted, entered the bios, change it to ganged, saved & exited. Then I shut down and popped the 2nd stick into slot 2 and still no boot. I put it back in 3 and to boots fine. CPU-ID lists it at 4 gb and single channel still.

If it was booting for the sticks in slot 1 & 2 and listing it as single channel this would have fixed it but with a stick in 2 (or 4) the system just doesn't boot, nothing on screen at all (monitor stays in standby mode, orange light).
a c 177 V Motherboard
June 14, 2009 11:50:22 PM

Okey-doke; first trick didn't work! I'm going to look and see if anything else in the BIOS settings jumps out at me, but I think I'm going to finally have to 'take the bull by the horns' here, and hunt up the design specs for the AMD processors and chipsets to see what's going on at the basic hardware level. See, I've kind of 'grown up' with the x86 Intel stuff, so, having read all the spec sheets for the CPUs and chipsets, I have a pretty good grasp of what's actually cooking there at the chip level (although I keep swearing that, one of these days when I've got some spare cash kicking around, instead of cobbling together yet another machine, I'm gonna 'skip one', and pay a couple of grand for a really good logic analyzer!), and they help - the 'innards' of the last dozen or so memory control hubs (northbridges) have just been a progressive riff on a familiar chord - they work the same, but have gotten to exercise more 'register-level' control over finer and finer details of timing issues, both between the MCH and the memory, and the mch and the processor; that said, the AMDs are kind of alien to me - they don't use the northbridge to 'talk' to the RAM. Now's as good a time as any, I guess, as Intel has decided to take the same path with the new i7s; and I'm certainly 'gonna wanna' play with one of those as soon as the 35nm's come out, and some of the 'beta' headaches have been solved by those braver than me! Anyways, for me, this stuff's got to get to the sort of 'instinctive' level; at some point, between reading what the BIOS settings do, and 'soaking myself' in the tech specs, it all 'clicks', and I get sort of an intuitive grip on what's happening - why the limits are where they are, why you need a little more voltage to 'swing this' at that speed, it all just makes systemic sense, it's a discernable pattern with a lot of room for variation, but a basic underlying 'harmony'... If I don't find anything obvious tonight, this'll probably take a day or two, as I'm rooting around trying to find a job, as well, and have to give that first priority, but, believe me, it will get done soon, 'cause, well, I just love this stuff - it's fascinating beyond description; especially as I've screwed around with this stuff since a first Commodore 'PET', and hacked my first hardware on a Z80 KayPro running (lovingly hand assembled) ZCPR3 - then, we knew what was in the BIOS, as we had all contributed a piece here and there... (Thet reminds me - if anyone reading this knows where I could find source code for a fairly recent BIOS, I'd kill to get a look at it!)
a c 177 V Motherboard
June 14, 2009 11:59:50 PM

Oops - mind wandered off so abruptly, I forgot to tell you what I'm supecting, and going to be looking for in the specs - what I'm searching for is a common 'choke point' where one component failure (or mal-adjustment) might cause the oddball combination of symptoms you've got. Something that will cause a complete POST failure should be giving us a pretty good clue as to what its root cause could be, but, not knowing enough about hypertranspot and its ilk, its not 'jumping out' at me!
June 16, 2009 10:54:46 PM

I have the same mobo and are you sure that your memory is in the accepted memory list. The only 2 Gig sticks that I found that were 'of performance' where the Corsair Dominator but its been a few weeks since I looked at the list. Maybe they were the only ones I liked for whatever reason. I wish I would've got 8 Gigs of DDR2 800 though.
a c 177 V Motherboard
June 17, 2009 12:24:31 AM

Lots of memory that will work never makes the approved list - it's endemic to the industry. For GBs, what happens is the approved memory list is made up when the MOBO is introduced from sticks they have been provided samples of, and never updated thereafter; in addition, many of the memory manufacturers that you'll see there you've never heard of, as (and I've said this before) I'm sure you can pick them up at any gas station in Taiwan, but they're not to be had here. That's also why, for a lot of boards, there are scads of 512M and 1G sticks, but few 2x2s and 4x2s...
July 20, 2009 11:21:02 PM

having the same problem, almost the exact same system, 850W ps, same video card, same memory, same cpu with dual fan cooling. I'll try the single chip boot, but with two ddr2's in slot 1 and 2, no MB beeps, no video....
July 21, 2009 5:30:39 PM

As I understand, 1066 on this board is only available with an AM3 cpu. Yours is an AM2+ I believe.
August 3, 2009 1:36:11 AM

Am2+ does allow 1066 ddr2 what it does not allow is ddr3 memory. And ganged or unganged does not have any thing to do with duel channel memory. If you multitask set it to unganged if you don't set it to ganged.
August 13, 2009 1:23:56 PM

i am having the same problem with the mobo i just bought but it does not boot no matter the ram configuration
a c 177 V Motherboard
August 13, 2009 2:25:02 PM

To quote the manual:
Quote:
"DCTs Mode
Allows you to set memory control mode.
Ganged Sets memory control mode to single dual-channel.
Unganged Sets memory control mode to two single-channel.(default)"


Check carefully that:
There are mounting standoffs only in postions where the MOBO has a mounting hole
The fan/heatsink has all its pins properly inserted and locked (check back of MOBO)

Strip the system to:
Keyboard
GPU and monitor
One stick of RAM in slot closest to CPU
All power plugs - ATX 20+4 or 24, ATX 12V_2x4, any plugs required by GPU
Front panel connectors - especially 'case speaker'
Place a jumper on RST_CMOS pins
Remove jumper from RST_CMOS pins

Power up
If you get a screen, enter BIOS and select 'Load Optimized Defaults', save and exit...
Power down, reassemble machine - if you have any USB devices beyond keyboard and mouse, add them one at a time, reboot, add another - USB can be a killer for GB MOBOs...

Good luck!

Bill
August 27, 2009 10:34:48 AM

There are a number of posts on various forums re this. I have this MOBO and this exact problem. I went and looked at the GB website and checked for memory compatibility and just under the section on DDR2 1066 there is a red message that says "Note: Due to AMD AM3/AM2+ CPU limitation, memory module DDR2 1066 or above speed is only supported by 1 dimm per channel." which if I interpret this correctly means you can only install 2 DIMMS, not 4. All my testing seems to confirm this. I figured I could run 4 x 1GB DIMMS at 800MHz instead of 1066 but so far no joy despite each pair of Corsair DIMMS testing OK with memtest. Of course, I'm only in this position because I bought the extra 2 x 1GB DIMMS to expand the memory and now find I'm screwed. For what it's worth, I suspect that if you install 4 DIMMS you risk damage to the DIMMS as I've already replaced 2 pairs on seperate occassions and now on reflection think I know why.
!