Sign in with
Sign up | Sign in
Your question

ASUS P5QL Mobo dosent see my HDD

Last response: in Motherboards
Share
June 13, 2009 6:08:52 PM

So like the title says, my asus motherboard does not see my sata hard drive. This problem probably came from another, so here is the story. A few days ago I misclicked when turning off my computer and accidentally put it in sleep. Just after misclicking I tried to wake it back up to turn off. When clicking didn't do anything I reached over to click the power button, and nothing happened. I killed power and then tuned it back on only to find that it was stuck in sleep mode or something like that. After checking my connections and looking at some forums I decided the only way to wake my computer back up was to take out the motherboard battery and put it back in. (I am not sure if that was a good idea, but at the time I was happy that it worked.) After booting back in I restarted and it worked again. (After fixing the first problem I successfully booted two times) A few hours later I turned off my computer for the night. (Note: There were windows updates when I turned it off, so I started them at turned off my screen and heard my computer shut down 30 minutes later) When turning my computer on the next day it said to insert boot media and click a key, so I restarted and went into the bios. It turns out that my bios does not recognize my sata hard drive (seagate 500g). I have updated my bios to the latest version and it still does not work. I have checked my wiring and the hard drive is powered on and connected. The front panel of the computer even reads that the hard drive is connected.
I included the long version just in case any of it helps, for I have no idea what the problem is. At first I thought an old bios was not compadable with my processor, but I flashed the bios to the newest version. I already posted the problem in a response to a thread with a similar problem, but I thought it would be better to make my own topic with this problem. Any suggestions would be much appreciated. Thanks!

Specs - ASUS P5QL Mobo, Intel q9550, Seagate 500g HDD, 2 gigs Crosair ddr2 ram, cooler master 430w psu, 3870 gpu (for fear that a lack of power is the problem I put my old x850xt in) .. and thats all that should really have any impact.
June 13, 2009 7:30:20 PM

Some more information -

I tried to get linux running from a flash drive, but when loading it came up with the error "bois sata bug". That would fit with my theory, but why didnt flashing the bios fix this?

After the errors was given, the boot just carried on and now I am in Linux..

And again, thanks for any suggestions.
a b Ĉ ASUS
a c 229 V Motherboard
June 13, 2009 7:41:24 PM

Can you check the hard disk in another system or try a different one? Putting the system in sleep mode didn't cause that issue.
Related resources
June 13, 2009 8:07:28 PM

Thanks for the reply!
I have checked for a hard disk from linux and I dont see anything. Also, I mentioned the sleep mode issue (which is a rare bug that I found some other people to have) because to fix that issue I removed and put back in the battery from the motherboard which I think caused the bios bug.

a b Ĉ ASUS
a c 229 V Motherboard
June 13, 2009 8:20:17 PM

Quote:
I have checked for a hard disk from linux and I dont see anything.
What do you mean?
June 13, 2009 8:24:23 PM

When in Linux it does not show any connected hard drives. I looked on the system monitor and it does not recognize anything when searching for sata devices. It does recognize everything else.
a b Ĉ ASUS
a c 229 V Motherboard
June 13, 2009 9:31:58 PM

Then your hard disk probably is defective, but have you tested it in another PC to make absolutely sure? Also check the SATA and power connectors.
June 13, 2009 9:37:11 PM

I checked all of the connections, and I want to test on another PC, but I don't have another pc to test it on, and I am not sure how long I will have until I can work with a friends pc. But given the circumstances of the problem I am leaning against it being a hard drive failure and toward a bios issue. However, I will try to get hold of another computer to test my HD with. Thanks for the suggestion!
December 28, 2009 8:41:12 PM

Did this problem ever work out for you? i have a similar problem, but my mb wont recognize more than one SATA HD at a time
December 28, 2009 11:22:44 PM

Na, I just ended up getting a new hdd. I'm thinking that I hit the computer while I was trying to fix some simple problem that started it. Now I have an exernal though!
December 29, 2009 4:03:01 AM

I ended up fixing the problem for my comp. I updated the drivers to the most recent release, and changed the HD recognition mode to AHCI... did the trick
!