Sign in with
Sign up | Sign in
Your question

Disk label

Last response: in Storage
Share
July 26, 2010 7:41:22 AM

Hi,
I was trying to do a low level format (Write zero's) on a hard disk, and instead acidentaly deleted the disk label.
This has resulted in no MBR and the disk being regarded as all bad sectors.
I need to put the disk label back before I can write a new MBR and partition but don't know how. Google seems no help.
Has anyone any idea?
Thanks, John

More about : disk label

a b G Storage
July 26, 2010 12:31:38 PM

Have you tried the disklabel utility in windows?
m
0
l
July 27, 2010 10:18:36 AM

I can't use disklabel in windows.
If I put the drive as slave windose won't start.
I can't install windows because there is no disk label.
The only way I can get at the drive is using a live CD, and I have been unable to find any program which will let me give it a new label.
Any other ideas anybody?
Thanks, John
m
0
l
Related resources
July 27, 2010 3:29:34 PM

check your BIOS settings....a drive without a 'disk label' is effectively an unformatted drive.....windows will see them as the same......if its not booting, it either means you need to repair the MBR on your other drive, or you need to change the settings in your BIOS

also there is no such thing as master and slave in reference to sata drives
m
0
l
a c 362 G Storage
July 27, 2010 3:44:07 PM

By Zero-Filling a disk you SHOULD have written zeroes over the MBR / Partition Table sector, too, and wiped it out. But all that does is make it exactly the same as a brand new empty drive. Given that, you should be able to Install Windows to it using a Windows Install Disk, if that's what you are trying to do. Or, if you simply want to Create a Partition on it to store data in, you can do that, too, with any number of utilities, including Disk Management built into Windows. When you Create the very first new Primary Partition on the HDD, the process will write a new MBR / Partition Table to the start of the disk.

As uh_no said, there is NO Mater or Slave on SATA drives. So, if you moved around any jumpers on the SATA drive, go to the maker's website and find out the proper default position of jumpers and restore that. I don't know what you have, but you could have caused yourself a problem. For example, on WD HDD's there is only ONE jumper you might need to adjust, and that is for the uncommon case of a SATA II new drive connected to an older original SATA controller that operates at only 1.5 Gb/s. On the other hand, placing a jumper on the wrong pins on some WD units configures it a special way (PUIS, or WD calls it PM2 Mode) used almost exclusively for server systems and, in most common desktops, makes the HDD appear to be dead! So get the jumpers set right.

IF you actually have an IDE drive, then tell us so we can help you ensure all your IDE device jumpers are set right.

Now, back to assuming you have a SATA drive, and you're trying to install Windows on it. First question has to be: which Windows? Regardless of whether you are installing Windows, or just trying to create a Partition on this drive to use in a system that already has Windows installed on another drive you boot from, we have to deal with the fact that Windows XP in all its forms cannot handle SATA drives without some help. On the other hand, Vista and Win 7 both DO have built-in drivers for SATA and AHCI devices, so you should have no problem with those OS's.

You will need to set a parameter in your BIOS Setup according to your OS and planned use. IF you are trying to use a SATA HDD with Win XP, that OS must have an AHCI driver installed to use such a device (exception - see next paragraph). If you have Windows running already from another drive on this machine, and the new drive is solely to be used for data storage, then you can set it up as an AHCI device and install the AHCI driver in Windows. BUT if you are trying to install Win XP to this SATA HDD, there are other steps to take to allow it to access the device. The "best" way but slightly more complicated is to use a standard technique built into Win XP Install to install an AHCI device driver into Win XP at the very beginning of the process. There is an early prompt on screen that tells you to press "F4" if you need to install additional drivers, and if you do nothing it will just skip that. But if you press "F4" as prompted, you enter a small routine that allows installation, but ONLY form a floppy disk. You have to have the drivers as files on that diskette, and you have to have a floppy disk drive connected to your machine, at least temporarily, to do this.

The alternative most BIOS's allow now for people who have no floppy drive or choose not to go that route, is to change the way the SATA drive is managed in BIOS. Near where you make sure the SATA ports are Enabled, there is a place to set the SATA port Mode, with choices like, "IDE (or PATA) Emulation", "SATA", "AHCI", or "RAID". The last three ALL will require installing required driver files from a floppy disk. But if you choose "IDE (or PATA) Emulation", the BIOS will intervene and make the HDD appear to Windows to be just a simple IDE device it does have drivers for already, and things just work fine.

If you are using Vista or Win 7, they both have drivers for SATA devices built in, and the proper setting fro the SATA port Mode is "AHCI".

Unless you actually plan to use this disk (plus at least one other) in a RAID array, do NOT set the port mode to RAID.

So, depending on which Windows you are using or installing, make sure you set the SATA port Mode to the right one. THEN you should be able to access it properly, whether you're installing Windows (whichever) to it or just Creating Partition(s) to use for data.
m
0
l
August 3, 2010 6:19:53 AM

Solved!
It turns out the computer I was trying to use was the one it came out of, and which I had given.
There seems to be a problem with it somewhere, either the motherboard or CPU (Probably why I had it given).
I tried the (IDE) hard disk on another computer and had no problems partitioning and formating.
Thanks for everyone's help.
John
m
0
l
!