Sign in with
Sign up | Sign in
Your question
Solved

ASUS DRW-24B1ST HELP!!!

Last response: in Storage
Share
July 28, 2010 7:30:38 AM

Hello! I have a ASUS DRW-24B1ST and it worked great when I bought it for my new comp. Then last night when I shut the whole thing down for a nights rest and woke the next morning, there was a problem. The cd/dvd drive was no longer visible under Computer. I opened device manager and it's under the drive section with a yellow triangle and an exclamation mark near it. I tried updating the drivers but it says everythings up to date. I downloaded the drivers manually but both give me errors, and I even downloaded a program called "Mats_Run.dvd" to help identify and fix the problem. It found the problem and also, could not fix it.

I'm stumped, this just randomly happened when I booted the next day. The drive can open and everything, it's just unusuable.

Do I have to return it?

Thanks!

-Wubby

More about : asus drw 24b1st

July 28, 2010 9:35:19 AM

Images of what's going on:

http://yfrog.com/6bdriveerrorp

http://yfrog.com/nfdriveerror2p

http://yfrog.com/evdriveerror3p

Like I said, I downloaded the drivers manually, but I don't know where to place them. The first one I run is "ASUSDOS" which when I open it, CMD prompt comes up saying "C:\Drive\Desktop\DRW-24~1.03\ASUSDOS.EXE - This system does not support fullscreen mode. Choose 'Close; to terminate the apllication."

The second file is ASUSWIN, which when opened says "No matched driver detected ! This utility is only for ASUS DRW-24B1ST drive. Detected drives:"


Just thought I'd provide anything else to help get this resolved as soon as possible.
m
0
l
Related resources
July 28, 2010 1:37:27 PM

Thank you for replying :]

But I already tried that. In my first post I said ", and I even downloaded a program called "Mats_Run.dvd" to help identify and fix the problem. It found the problem and also, could not fix it."

So that idea is unfortunately out the window :[
m
0
l

Best solution

a b G Storage
July 28, 2010 2:21:07 PM

Missed that one. Never heard it called that before.

In the device manager, right click on the drive, and uninstall it, then restart. Windows will recognize the new hardware and reinstall it.

If that doesn't help, delete the upper and lower filters in the registry.
http://support.microsoft.com/kb/982116
Share
July 28, 2010 2:45:04 PM

Alright, now I'm completely puzzled. I removed the device and put in an old reliable IDE one that I had for a few years. I booted it up, and literally got the same exact error.

I'm simply flustered. I hope it isn't the motherboard, or any other hard ware that is making this happen. I'm at a loss, both cd drives do not work, saying there was an error while installing the drivers.
m
0
l
July 28, 2010 2:49:27 PM

aford10 said:
Missed that one. Never heard it called that before.

In the device manager, right click on the drive, and uninstall it, then restart. Windows will recognize the new hardware and reinstall it.

If that doesn't help, delete the upper and lower filters in the registry.
http://support.microsoft.com/kb/982116


Oh and I'm sorry, what do you mean delete the upper and lower registry filters? That part kinda lost me.

Uninstalling and rebooting has not worked for either drive.

Thank you again for the response
m
0
l
a b G Storage
July 28, 2010 2:59:31 PM

There is a step by step guide in that link on how to delete the upper and lower filters. It's a little different for each version of windows, so make sure you follow the guide for your version.
m
0
l
July 28, 2010 3:12:31 PM

Omg you guys did it!!!! WOOOO!!!

I went all the way to the UpperFilters, deleted them, but didn't see any Lower Filters. Regardless though, I ran the FixIt program, and it actually fixed it!

Thank you so much. This forum is awesome :D !
m
0
l
July 28, 2010 3:13:00 PM

Best answer selected by MercenaryWubby.
m
0
l
a b G Storage
July 28, 2010 5:28:09 PM

Good to hear. Thanks for the update!
m
0
l
June 4, 2012 5:06:48 AM

aford10 said:
There is a step by step guide in that link on how to delete the upper and lower filters. It's a little different for each version of windows, so make sure you follow the guide for your version.


Thank you! You also helped me. Same problem Windows-7 64-bit, same drive mysteriously disappeared in My Computer and showed yellow exclamation point in device manager. UpperFilter showed 'Gear____" (something like that). I also had a lower filter. Deleted both, rebooted and drive is back online and showing! I wonder what I installed that did it. I didn't notice for about a month, as I rolled back system restore as far as it would go (May 12th 2012) and it did not solve the problem, so it must have been something I installed in April. I don't recall what it was, but thank you!
m
0
l
February 2, 2013 9:20:54 PM

I was trying to figure this out for quite a while. The MS Fix It app did indeed fix it. Thanks!
mrbill
m
0
l
!