Sign in with
Sign up | Sign in
Your question

Monitor not displaying anything

Last response: in Graphics & Displays
Share
February 20, 2009 9:37:07 PM

I have an EVGA 780i motherboard, and I just recently installed an ATI 4870 graphics card. It worked for a week or so, I installed all the drivers, I could play games and everything, but now I have a problem. Whenever I boot, the fans whir really loudly, the LED screen on the mobo reads "FF" (which I think means successful boot), no beep is made, but the monitor is blank. It does not register anything, it just stays on standby. When I take out the graphics card and boot, the fans are MUCH more quiet, but still no beep is made (maybe the beep isn't necessary?)

System Specs:
WinXP SP3
EVGA 780i Mobo
E8400 Core 2 Duo (Intel) CPU
ATI Radeon 4870 Graphics Card
4GB Corsair DDR2 RAM
800W ABS power supply
WD Raptor 10k RPM SATA hard drives

More about : monitor displaying

a b U Graphics card
February 21, 2009 9:39:56 AM

All the fan noise is coming from the graphic card, that is why everything is much quieter with the card out......the GPU fan will run at 100% initially, and they are pretty noisy at full speed. However, it should throttle back as soon as you hear the successful POST beep.......
It is odd that you are not getting any error beeps, but FF does mean a successful post. Try removing and reseating your memory. If you are overclocking, set everything back to normal.
February 21, 2009 5:24:37 PM

Btw, it's a dell monitor, in case that helps in some way.

The light stays on orange for standby, and says that it has no signal.
Related resources
February 21, 2009 5:35:50 PM

My memory is normal, not overclocked.

So I should just take out the RAM and put it back in different slots?
February 21, 2009 6:21:56 PM

No, I can't see anything on the monitor. It just stays on standby and does nothing.
February 21, 2009 6:53:50 PM

Yeah I can't get into the BIOS, because my monitor acts as if nothing is plugged in. It does literally nothing.

I tried resetting the CMOS but nothing happened....
January 6, 2010 5:10:13 AM

i think is your ram problem.. try unplug one by one and boot, or try new ram.. :) 
!