Sign in with
Sign up | Sign in
Your question

4870 Crossfire problem

Tags:
  • Graphics Cards
  • Crossfire
  • Graphics
Last response: in Graphics & Displays
Share
February 21, 2009 5:17:20 PM

Hi everyone,

Last week I bought myself a second Powercolor Hd4870 pcs+ 1gb and i'm experiencing some problems to make it work in CrossfireX mod.

Components and os : Corsair hx620, e8400@ 3.3 ghz, 3gb ram kingston pc8500, 2x Powercolor hd4870 pcs+ 1gb, maxtor hard drive 250 gb, p5q pro motherboard,19" acer al1916w screen (soon getting a 22"), windows xp sp3.

Problems : I can't get the crossfire to work properly, it's enabled in the Catalyst Control Center but gpu-z indicates that it's disabled. Beside since I have installed it I haven't noticed any performance improvements in any game (Far cry 2, Crysis) or benchmark software (3d mark 2006). Both cards works fine seperately (I tested each of them).
I tried different Ati drivers such as the 8.10, 8.11, 8.12, 9.1, 9.2 without any results or improvements.
I formatted my pc, installed drivers seperately for each cards with again no results.
I really don't know what to do now and that's why i'm asking for some help.
Thanks in advance.

ps: my Fps rate in farcry 2 or crysis in crossfire mod with all setting at max and x4 anti-aliasing is around 30, my 3d mark06 score is around 14500.

More about : 4870 crossfire problem

February 22, 2009 11:09:49 AM

no one can help me ?
February 22, 2009 12:13:37 PM

I have yet to run a crossfire set up myself so I dont know much about them, but two things come to mind.

1. I know this is simple but you did connect them w/ the crossfire bridge right?

2. Is there a setting in the BIOS that needs to be enabled first?

Like I said I havent ran crossfire myself yet so these might be silly things to look at.
Related resources
February 22, 2009 2:00:15 PM

bonanzaguy said:
I have yet to run a crossfire set up myself so I dont know much about them, but two things come to mind.

1. I know this is simple but you did connect them w/ the crossfire bridge right?

2. Is there a setting in the BIOS that needs to be enabled first?

Like I said I havent ran crossfire myself yet so these might be silly things to look at.


Sorry I completely forgot to mention it but yeah I did connect them with the crossfire bridge. ( I tried with one and two crossfire bridges )
And I didn't notice any option in the bios that need to be activated in order to enable the crossfire, yet I'm wondering if some would appear if I flashed it ?
February 22, 2009 2:20:32 PM

How do you have the power supply connected to you video cards. I think that particular PSU comes with two 6 pin PCI-express connectors. What you have to do is use the supplied 4 pin molex to 6 pin pci express given with your video card package and connect it that way.

To tell you the truth I don't think you have enough amperage in your PSU to run 4870 in XF. Check this link out. I don't think that PSU is listed.
http://game.amd.com/us-en/crossfirex_components.aspx?p=...
February 22, 2009 2:49:05 PM

ragsters said:
How do you have the power supply connected to you video cards. I think that particular PSU comes with two 6 pin PCI-express connectors. What you have to do is use the supplied 4 pin molex to 6 pin pci express given with your video card package and connect it that way.


Yeah that's exactly what I did and as for power consumption it might be that but it would surprise me because according to benchmarks and reviews i read about the 4870 in crossfire, a basic setup like mine comsumes like 500 watts maximum ( with the screen and at 90% charge.).But it can be also some kind of incompatibility as you said, well I don't know.
February 22, 2009 2:58:32 PM

Don't get into flashing. It shouldn't be necessary. Your 3DM06 score should be higher than that with two 4870s.

So first, get into CCC and look at the 3D settings. You need Catalyst AI enabled to run xfire. Set it to the lower setting on the left side of the slider. You can also double check and enable the xfire symbol. If you don't see it in the upper right corner when you run FC2, it isn't working. You can enable it by right clicking on your CCC tray icon and under your first 4870 there are xfire settings to enable the indicator.

Second, if you don't see the xfire symbol, I would run each card individually and make sure that they are working on their own just to check that your new card is working if you haven't already. Your PSU should be ok to run xfire. I am running two 4870s off a 650W PSU. Unless there is a problem with your PSU, I would think 620W would be ok.

I found that the only BIOS setting that affects xfire is setting your PCIe frequency manually. I had to leave it on auto in my BIOS for it to work. If I forced the frequency to 100, xfire wouldn't work for me. Other than than, there isn't a BIOS setting that I know of that would need to be changed.

If it is still not working then I would uninstall all of your video drivers and start with a fresh install. I am not sure what you mean by installing the drivers for each card. All you have to do is connect the two xfire bridges and then install the current drivers once (but don't forget to always uninstall your previous drivers)

Seeing that you have went through a lot of drivers, I would go through add remove programs if you haven't already to clean out all of the ATI drivers...reset, delete all ATI files (hopefully you don't have nvidia drivers?) and then install the current drivers.

Hopefully some of this helps. Good luck!





February 22, 2009 8:03:02 PM

SpinachEater made some good points.
To uninstall and reinstall your video drivers follow these directions.

1. Download catalyst 9.2 from ATI or techpowerup.com and put it on your desktop.

2. Download driversweeper, install it and put the icon on your desktop.
http://www.guru3d.com/category/driversweeper/

3. Double click on the catalyst 9.2 exe file and run it as if you were going to install it but when they give you the option of install or uninstall click uninstall.

4. Reboot the computer when asked to after the un-installtion process is complete.

5. During reboot make sure you do the necessary procedure to get into windows in safe mode.

6. When in safe mode double click the icon for driver sweeper and clean all the ati display driver registries and if you ever had nvidia drivers clean those too.

7. Reboot your computer.

8. Double click on the catalyst 9.2 exe file and follow the installation process and your done.
February 22, 2009 9:34:02 PM

I have used driversweeper in the past and it works well but the last time I used it the program crashed in the middle of the process and fd up my registry. I wouldn't suggest using it but if you do, at least cover your arse and backup your registry before hand.
February 23, 2009 12:06:11 AM

I have never run crossfire myself. However, I have read a lot about it.

One thing that comes to my mind is that you could be CPU bottlenecked. If you are using a 19" monitor, then you are probably running it at 1680 x 1050 which would be more CPU bound than GPU bound.

My guess is that your E8400 at 3.3 is already maxed out feeding your first 4870 and therefore it cannot feed any data to your second 4870.

I run Far Cry 2 at 1920x1200 DX 10 Very High 0 AA using my E7300 OC to 3.4 and 8800GT OC to 690. I use a second monitor to monitor my CPU usage. At this setting, my CPU is already maxed out on both cores. (On built in benchmark, I get avg 45fps)

Check out
http://www.anandtech.com/mb/showdoc.aspx?i=3506&p=6
http://www.tomshardware.com/reviews/core-i7-gaming,2061...

To fully take advantage of 4870 CF, I think you would need a Core i7.

Good Luck!

jkflyer
February 23, 2009 12:42:19 AM

jkflyer said:
I have never run crossfire myself. However, I have read a lot about it.

One thing that comes to my mind is that you could be CPU bottlenecked. If you are using a 19" monitor, then you are probably running it at 1680 x 1050 which would be more CPU bound than GPU bound.

My guess is that your E8400 at 3.3 is already maxed out feeding your first 4870 and therefore it cannot feed any data to your second 4870.

I run Far Cry 2 at 1920x1200 DX 10 Very High 0 AA using my E7300 OC to 3.4 and 8800GT OC to 690. I use a second monitor to monitor my CPU usage. At this setting, my CPU is already maxed out on both cores. (On built in benchmark, I get avg 45fps)

Check out
http://www.anandtech.com/mb/showdoc.aspx?i=3506&p=6
http://www.tomshardware.com/reviews/core-i7-gaming,2061...

To fully take advantage of 4870 CF, I think you would need a Core i7.

Good Luck!

jkflyer



How can you say that the reason why his crossfire doesn't work is because of a cpu bottleneck? The only thing that would happened if there was a bottleneck would be lower fps. Secondly he definitely has enough juice in his CPU to make those video cards show a lot of potential. Core i7 CPU's will only improve FPS by very little if any. Thirdly, usually a 19" monitor means either 1280 x 1024 or 1440 x 900.
February 23, 2009 9:30:20 AM

ragsters said:
SpinachEater made some good points.
To uninstall and reinstall your video drivers follow these directions.

1. Download catalyst 9.2 from ATI or techpowerup.com and put it on your desktop.

2. Download driversweeper, install it and put the icon on your desktop.
http://www.guru3d.com/category/driversweeper/

3. Double click on the catalyst 9.2 exe file and run it as if you were going to install it but when they give you the option of install or uninstall click uninstall.

4. Reboot the computer when asked to after the un-installtion process is complete.

5. During reboot make sure you do the necessary procedure to get into windows in safe mode.

6. When in safe mode double click the icon for driver sweeper and clean all the ati display driver registries and if you ever had nvidia drivers clean those too.

7. Reboot your computer.

8. Double click on the catalyst 9.2 exe file and follow the installation process and your done.

That's what I did everytime, I even formatted and reinstalled the system recently without any results.

[/quotemsg]So first, get into CCC and look at the 3D settings. You need Catalyst AI enabled to run xfire. Set it to the lower setting on the left side of the slider. You can also double check and enable the xfire symbol.[/quotemsg]

The catalyst A.I was enabled by default but what do you mean by "double check" and "enable xfire symbol" (if you do mean to activate it in the CCC I did it of course.)


February 23, 2009 9:30:53 AM

Oh ok. I got his current 19” monitor and his future 22“ monitor confused. I was thinking of 1680 x 1050 for the 22” monitor. In addition, I am thinking that his frame rates for 4870 single vs 4870 CF are identical because he said that “I haven't noticed any performance improvements in any game. (Far cry 2, Crysis)”

At any rate, at lower resolutions, I think the GPU is not fully utilized because of CPU bottleneck. Usually this is not a problem because usually your frame rates at lower resolutions are fast enough, even if your GPU is not being fully used. However, this could become an issue if your frame rates dip due to turning on all the eye candy.

There was a Far Cry 2 benchmark done by Guru 3D using Core 2 Duo E8400 Processor @ 3.0 GHz (FSB 1333). According to the charts, this CPU shows a bottleneck at 1280 x 1024 as evidenced by 4870 1GB and 4870 X2 scoring 53 and 54 fps respectively.

http://www.guru3d.com/article/far-cry-2-pc-vga-graphics...

Like I said, I have not tried crossfire firsthand. One way to see if there is a CPU bottleneck would be to try comparing the results with E8400 at 3.0 vs 3.3 or at 3.3 vs 3.6.
February 23, 2009 3:34:59 PM

edikodom said:
That's what I did everytime, I even formatted and reinstalled the system recently without any results.

So first, get into CCC and look at the 3D settings. You need Catalyst AI enabled to run xfire. Set it to the lower setting on the left side of the slider. You can also double check and enable the xfire symbol.[/quotemsg]

The catalyst A.I was enabled by default but what do you mean by "double check" and "enable xfire symbol" (if you do mean to activate it in the CCC I did it of course.)[/quotemsg]


haha, sorry. Double check as in make sure it is enabled. Hmm...so that is weird. What is your PCIe frequency set to in your BIOS...is it auto or a number like 100? Can you get the xfire symbol to appear for any 3D application?
February 23, 2009 3:50:18 PM

SpinachEater said:
So first, get into CCC and look at the 3D settings. You need Catalyst AI enabled to run xfire. Set it to the lower setting on the left side of the slider. You can also double check and enable the xfire symbol.


The catalyst A.I was enabled by default but what do you mean by "double check" and "enable xfire symbol" (if you do mean to activate it in the CCC I did it of course.)[/quotemsg]


haha, sorry. Double check as in make sure it is enabled. Hmm...so that is weird. What is your PCIe frequency set to in your BIOS...is it auto or a number like 100? Can you get the xfire symbol to appear for any 3D application?[/quotemsg]

I'm going to check brb.
February 23, 2009 4:03:47 PM

Ok so it is on 100,I can't put this specific option on auto but if I turn the AI overclock tuner on auto i think the pcie frequency should be set on auto by default. ( because the PCiE frequency and fsb frequency options both disappear then.)

Sorry I can't edit my message.
February 23, 2009 7:36:29 PM

Do you have a conflict in your hardware profiles by chance?

Edit: I am not at my computer but I think if I set my PCIe frequency to 100 manually I will not get xfire. I am not sure why that happens or if it is supposed to happen or if there is a certain xfire frequency it needs to be at but you might want to look into how to get it set to auto.....consult your manual for that one.

Ok, I will do it for you. I am looking at it right now and it says that if you turn AI Overclock Tuner to manual then you will be able to see and adjust the PCIe Frequency. It looks like it has an auto option but you say it doesn't? You would think that it would stick to auto if you have the AI tuner on but maybe if it force it that would help. I am running out of ideas for you!

February 23, 2009 7:46:22 PM

SpinachEater said:
Do you have a conflict in your hardware profiles by chance?


No.
!