Sign in with
Sign up | Sign in
Your question

Upgrading from integrated graphics

Last response: in Graphics & Displays
Share
February 22, 2009 7:51:53 AM

Dear all,

I wish to upgrade from the integrated graphics card on my pc to a dedicated one. I'd seen an XFX card
at the local store the other day - a Nvidia Geforce 8600GT 512mb ddr3 ram - @ ~$40 USD.

So my queries are -

1. Can I upgrade from the integrated graphics?
2. Will it be possible to go for a Nvidia GPU, given that I have an Ati chipset?
3. How do I know which slot is required on the motherboard for the upgrade to be possible [i.e. what
spec should I pay most attention to]?
4. How do I disable the IGP? [In fact, any links to a step-by-step would be much appreciated]
5. Will this particular card max out the full potential of my CPU or is it possible to go for a higher card
before my CPU becomes a bottleneck?
6. Any better cards @ ~$40-$50 USD? [I'm on a tight budget]

Here are my specs -

Motherboard: Intel D102GGC2 Version AAD42789-203
CPU: Intel(R) Pentium(R) 4 CPU 3.06GHz Prescott Socket 775 LGA FSB 533.4 MHz L2 Cache 1024 KBytes
BIOS Vendor: Intel Corp. Version GC11020M.86A.1065.2006.0502.1638 Dated 05/02/2006
Number of CPU(s): One Physical Processor / One Core / 2 Logical Processors / 64 bits
Display Adapter: ATI RADEON XPRESS 200 Series Internal DAC(400MHz) Memory 256 MBytes
Monitor: Viewsonic VA712 17" (34 cm x 27 cm) Native Resolution 1280 x 1024 @ 60Hz Aspect Ratio 5:4

Please bear with me as I'm a total newbie. Thanks for all your help. Its very much appreciated.

a b U Graphics card
February 22, 2009 10:55:10 AM

All you need is a PCIe expansion slot, which your should have. So yes, you can upgrade to the 8600GT. For your system, that card would be a good match. For $40, I don't know of anything you could get that would be any better. Maybe somone else will chime in who knows of a better deal, but really that is not bad for that card.

The chipset type on the motherboard only matters if you are running 2 video cards in Crossfire, or SLI. A single card makes no difference at all. Any brand video card will work perfectly fine with any chipset.

Most modern boards will automatically find your new PCIe card, and switch over to it by themselves, you shouldn't have to do anything. Simply plug it in and go.

You should, however before installing the new card into your system, uninstall all the ATI software and drivers, and reboot with the system running in standard VGA mode, with only the generic Windows VGA driver. Then shut down again, remove power, install your new card, reconnect power, boot, and install the nVidia drivers.
Do it in that order to avoid issues with driver conflicts, etc.
February 23, 2009 1:44:40 PM

Thanks a lot for your reply, jitpublisher.

This is what i got off the manufacturer's site -intel - about the motherboard D102GGC2

Expansion Capabilities-

One PCI Express* x16 bus add-in card connector

So I'm good to go, right?

& is XFX a reliable company, or should I consider other manufacturers?

Also what PSU would I need to use? I'll try & give you the specs of my PSU if I can.

Thanks!
Related resources
February 23, 2009 5:59:28 PM

Look for Nvidia GeForce 9500gt need a 350watt PSU it is very inexpensive and is what i use, like $50 to $75
February 27, 2009 6:15:51 PM

Thanks for all your replies, guys. Will probably go in for the 8600gt cos here thats the only card available at that price. Thanks yet again. Ciao!
April 27, 2009 8:50:44 PM

jadavis1992 said:
Look for Nvidia GeForce 9500gt need a 350watt PSU it is very inexpensive and is what i use, like $50 to $75



Hello, im having some trouble installing my new Nvidia 9500gt XFX graphics card. When i install it into the slot and boot, i dont get a video signal. I have an Intel D915GUX motherboard, P4 3.4ghz processor, 4gig crucial memory and 430 watt psu running in my system. The motherboard is brand new as i had to replace it due to my xfx 6600 card blew on my old but same mobo. I have tried to remove and replace the battery and got it up and running but when i restart it just did the same thing. I also tried to update the bios and chipset but still nothing. Do you have any suggestions Please
!