Sign in with
Sign up | Sign in
Your question

DVD drive showing up in Safely Remove Hardware

Last response: in Storage
Share
August 3, 2010 5:27:22 AM

I just got a new Toshiba M640 and for some reason, the DVD burner shows up in the Safely Remove Hardware icon with my external hard drives and thumb drives. While it's not that big a deal, I have occasionally unmounted it and needed to reboot my computer to even open the drive.

The drive is a HL-DT-ST DVDRAM GT30N. Thanks in advance.

a c 103 G Storage
August 3, 2010 2:39:01 PM

This is normal for laptops, I think every laptop I have seen shows the optical drive in that icon.
m
0
l
Related resources
a c 103 G Storage
August 3, 2010 4:17:22 PM

sminlal said:
If you're running Windows 7 then check out this Microsoft paper - it describes how to configure the devices on your SATA ports as "removable" or not:

http://www.microsoft.com/whdc/device/storage/eSATA.mspx


That's an interesting paper, but it's made for system builders designing chipsets, not end-users.
m
0
l
August 3, 2010 6:57:27 PM

I'm running Win7 but is there a tl;dr (too long didn't read) version of that paper? I'm not exactly the most tech savvy person.
m
0
l
a c 103 G Storage
August 3, 2010 7:18:53 PM

Don't worry about that white paper, I took a peek at it, and it's geared towards people that design systems not consumers.

Just be carefull what you remove using the hardware remove wizard.
m
0
l
a c 415 G Storage
August 3, 2010 11:43:46 PM

hang-the-9 said:
That's an interesting paper, but it's made for system builders designing chipsets, not end-users.

The section titled "Incorrect SATA Configuration" gives the registry settings needed to configure SATA ports as internal - if you apply those settings then the device attached to that SATA port will no longer be considered to be "removable" and it won't show up in the "Safely Remove Drives" icon.
m
0
l
August 4, 2010 4:33:54 PM

I tried entering the following command given in that paper into the command line for different channel numbers, but it does not fix anything. Do I need to change the name of any of the folders to get it to work?

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001
m
0
l
a c 103 G Storage
August 4, 2010 4:36:34 PM

djwhack03 said:
I tried entering the following command given in that paper into the command line for different channel numbers, but it does not fix anything. Do I need to change the name of any of the folders to get it to work?

reg.exe add "HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0" /f /v TreatAsInternalPort /t REG_DWORD /d 0x00000001


Looks like you have to know what port the drive is on, and change that one.
m
0
l
August 4, 2010 5:01:02 PM

hang-the-9 said:
Looks like you have to know what port the drive is on, and change that one.


I'm sorry if the answer to this question is simple, but how do I find that out?
m
0
l
a c 415 G Storage
August 4, 2010 7:45:41 PM

djwhack03 said:
I'm sorry if the answer to this question is simple, but how do I find that out?

- Start -> right-click "Computer", click "Manager" -> click "Device Manager" in the left pane

- Open up the "Disk drives" (or in your case, "DVD/CD-ROM Drives") section in the right pane

- Right-click on the disk drive in question and select "Properties"

- Under the "General" tab, look at the "Location" field for the "Channel" number.

Note that you'll have to reboot your system before the change will take effect.
m
0
l
October 15, 2013 8:39:10 AM

I know this is an old post, but it shows up early in search results for people that may be looking for this solution and I see the solution has not been posted yet.

For anyone that has a DVD drive showing up in Safely Remove Hardware, or any other hard drive showing up there, go to the vendor for your computer, look in the drivers for the latest Rapid Storage Technology driver. I just fixed it going from ver7 to ver9 on vista and can guarantee this is the fix, it's fast and easy too.!!

m
0
l
!