Sign in with
Sign up | Sign in
Your question

Problem getting picture via dvi to hdmi

Last response: in Graphics & Displays
Share
February 23, 2009 12:00:55 PM

I have a problem getting picture on my LCD (Sony KDL-40W2000) from the PC (PowerColor Radeon HD 4870 "PCS" 1GB). I use an adapter dvi->hdmi from the PC and a hdmi cord from there to the tv. My computer is fairly new and I built it myself. Have tried possibly every adjust in CCC with no result and of course with the newest driver.

The only time a got a picture on the tv is when the system reboot after installing new ati drivers, I can see picture on the tv until the vista desktop are being loaded and then the tv just blanks end gets no signal.

There are no problem with the tv it works fine and should not be the weekest link. Obviously there must be some problem but dont know what it could be.

I have also update to the latest BIOS version and after that I never had an image on the tv, not even when I install new drivers. CCC shows that the tv is connected and everything but there is just no signal to the tv, its blank.

Could anyone please tip me on what the problem could be?

Greatly thankfull
February 23, 2009 10:33:50 PM

could be a couple of things.

1st the display resolution might be set to something that the tv doesnt like. ie 640x480. try setting it to 1280x720 ( 720p) and see if it works.
2nd hdcp ( yay broken ass copy protection) normally this will either force downscaling to 480i or disable video or audio if it detects a non hdcp compliant audio/video output. a non hdcp compliant monitor will do this. try unplugging any other audio/video cables then boot cleanly. yes audio cables might affect the display.
3rd your tv is set to only accept x format on the hdmi port ( in the tv setup) make sure it set to the same resolution as the display output or put it on auto.
4th you have the component breakout cable plugged in.

does the display work if you try component out to the tv ( the red blue green rca cables) that tv should have component in ( 1080i might not be great but at least you can diagnose whats going on)?
February 28, 2009 5:20:03 PM

Hi Ignatowski, thanks for the good replay!

Have tested every setting, should not be a problem, it's set to 1080p bu default.

Can't find where to set format on the hdmi port, assume its auto. The tv showed that it displayed 1080p, when it work without display drivers.

The component out works fine, have tested it with a xbox.

Is it really the TV that's the problem, couldn't also be the graphics card?
March 13, 2009 7:04:29 PM

I wonder if anyone know what this BSD stop code means:
0x0000001E(0xFFFFFFFFC0000005,0xFFFFF80001C63B22,0x0000000000000000,0xFFFFFFFFFFFFFFFF)

I dont only have problem with the picture to the tv, but also stability problem. Can these two problems maybe have anything to do with each other? How do a test if the grapic card is guilty one?

Thankfull for any help!
!