Sign in with
Sign up | Sign in
Your question

MA790X-UD4P - no drives detected in BIOS

Last response: in Motherboards
Share
June 25, 2009 9:34:21 AM

Greetings... so let's get right to it:

I'm using a Gigabyte MA790X-UD4P motherboard. This board features 6 yellow SATA connectors, and 2 purple connectors ( I believe living off the PCI express bus). I have plugged in, simultaneously, six (6) known working, functional hard drives into all six, yellow SATA connectors, and when I boot the box and enter the BIOS, I get nothing. (I'm using AHCI to take advantage of the native command queing features.) When I enable AHCI, I get a prompt saying "AHCI Drive Init...." then "no disks detected." I've tried numerous combinations of enabling/disabling the onboard/gsata controllers, but I can't make any progress...

The kicker: I have already RMA'ed this board thru Newegg once already for the EXACT same issue. Am I doing something wrong? The chances that all 6 drives im plugging in together being bad are tremendously low, considering they were taken out of another server, prior to this new build involving this board. What are the odds I get TWO bad apples, straight in a row... Thank you so much for any and all input. If you need more information, I'd be happy to provide it. It's 5:30AM and I'm at my wits end!

Warm regards,

sp4rk
a b V Motherboard
June 25, 2009 2:05:08 PM

This may sound stupid, but you do have power connected to them?
Have you tried, just for the heck of it, setting the SATA ports to IDE mode?
a c 177 V Motherboard
June 25, 2009 5:27:41 PM

Yup - when a whole bunch of drives vanish - the first suspect is power; if you have a modular supply, likely all your SATA power plugs are hung off one cable - a malfunctioning or 'backed-out' pin at the PSU will make everyone 'go bye-bye'...
Related resources
June 25, 2009 6:12:45 PM

Thank you jitpublisher and bilbat for your responses.

When I test the two GSATA purple ports with my two (2) x 750Gb drives, they both appear, so power is getting to those two drives. Now, this doesn't rule out the possibility when all six hard drives are plugged into the other SATA area (yellow ones), the PSU freaks out. Is this a logical line of thinking?
a c 177 V Motherboard
June 25, 2009 6:51:05 PM

That's entirely possible, too... One factor to consider is that, even if your PSU rail is rated OK for the entire load, at power-up, your drives are all 'spinning-up' at the same time, drawing higher than rated current, which could be 'tripping' the rail; this is the reason why most hardware-based RAID cards support what's called 'staggered spin up' - to keep the start-up current draw from say, eight or twelve drives, from 'hitting' the PSU all at once...
June 25, 2009 11:47:10 PM

Well, I think I've ruled out the PSU being bad or getting overloaded:

I unplugged all but one drive -- I plugged it into one of the two (purple) GSATA controllers, and it worked fine in IDE and AHCI mode - it listed in the BIOS both times.

I then unplugged it, and moved the SATA cable to the onboard controller ( six [6] yellow connectors) and it didn't list in the BIOS. The onboard SATA simply doesn't seem to work. This is again another defective motherboard, or I'm doing something wrong. Again, I toggled the settings under "Integrated Peripherals" with no luck at all.

I'm running out of ideas and the thought of waiting another week and a half to go through another RMA process is upsetting. Thank you so far.

Regards,
sp4rk
a c 177 V Motherboard
June 26, 2009 12:28:08 AM

I just posted the whole 'check this in the BIOS' list for someone else this week - I'll dig up a pointer for you so you can double check. Having two boards in a row with the same problem is really improbable (I'd rush out and buy a couple lottery tickets); but, then again, so is human conciousness! :o 
June 26, 2009 10:09:00 PM

Thank you for the additional suggestions. I will test some more this weekend and report on my findings!

Regards,

sp4rk
!