Sign in with
Sign up | Sign in
Your question

Screen flicker is driving me nuts

Last response: in Graphics & Displays
Share
February 23, 2009 3:25:28 PM

Hi folks, i got a problem (actually i've got a multitude of problems, but this isn't the time or the place to get in to that :pt1cable:  )

A few months ago I set-up my new PC:

Q6600 processor (everthing now running at stock due to some instability issues!)
Asus Rampage Formual Mobo
2 off HD4870 CF
Zalman 1Kw PSU
2Gb DDR2 800 RAM
OS: Dual boot Win XP Pro / Win7 Ultimate 64 Beta
CCC Version: 2009.0113.2222.40119

But here's the thing: i've got a screen flicker that just won't go away.

I've lost count of the things i've tried to countermeasure it, but nothing works 100%. The only thing that has helped a bit is to keep the memory clock to it's minimum setting of 900MHz on the card that's out-putting to the monitor. It doesn't seem to make a difference now high the clock speeds are on the other card.

Strangely, the flicker all but disappears when the cards are being used. E.g. when playing a game or watching a film.


Does anyone have any experience of this or know of a fix? I can't tell you how annoying this is!

Any help appreciated


a b U Graphics card
February 23, 2009 4:02:07 PM

Which monitor do you have? Screen flicker is often caused by Hertz being set too high. 60 hertz should not flicker.
a b U Graphics card
February 23, 2009 4:10:47 PM

Kinda sounds like a refresh rate problem. I'd double check the Hertz level on your settings for the monitor. Also keep in mind, when at the desktop your video card isn't pushing FPS like it does in games. Open FRAPS some time and set it to show up at desktop. With things at idle, and no mouse movement, it'll show really, really low FPS.

FPS isn't your issue. However, it can explain why the flicker goes away in games. Now your image is being replaced very rapidly, where as at desktop it's the same image over and over, and your Hertz issue may be more readily seen.

Also: If your monitor happens to be an older CRT (glass front, big, heavy) monitor. Make sure you don't have any magnetic or electronic devices to close to it that could be interfering with its ability to display properly. (if you suspect an item, just move it) Seen that happen once or twice. ;) 
Related resources
February 23, 2009 4:19:08 PM

Try disabling any overclocking in the Catalyst Control Center (not just setting to defaults). I had that problem on a slightly older ATI card.
a b U Graphics card
February 23, 2009 4:25:34 PM

I would check your monitor refresh rates, if it's a CRT, if it is LCD 60Hz is fine. If it is CRT and it is set at 60Hz I would change that to something higher like 72 Hz. The human eye is very sensitive to 60Hz and if you have florescent lights they also are at that spot and can make this effect worse. Normally the speed of your memory on the video card isn't going to cause an issue unless you have a defective card.
February 23, 2009 4:42:06 PM

Change your refresh rate to 60hz. Or change the monitor if that doesn't work.
February 23, 2009 5:42:53 PM

Hi and thanks to all for the responses.

My monitor (LG W2252TQ) is currently set to 60Hz.
I've tried it on a different LCD monitor in the past, but this flickered as well.

Chances of it being a defective card seem to be minimal since both cards do the same thing individually (i.e. not CF'd) and in both PCIe ports.

Wouls all this rule out it being a refresh issue?
September 27, 2009 11:00:18 PM

I am also operating on an LG W2252TQ and experiencing the flickering problem. Mostly this is noticable when I type or use my mouse (especially on mouse-over). I have set my refresh rate to 60hertz but still no fix.
September 28, 2009 7:43:11 AM

Mine's fixed now. It was being caused by memory clock frequency changes in the primary display adaptor. I used the Radeon BIOS Editor to set the memory clock at a fixed frequency - no more flicker!
!