Sign in with
Sign up | Sign in
Your question

Strange power behaviour!

Last response: in Components
Share
April 27, 2009 9:02:28 PM

I bought a used Compaq SR5110NX on eBay. It's an Athlon 64 3800+. Motherboard is an MCP61PM-HM. (I have another one just like it which behaves normally.) Everything works fine except the power behaves very oddly. If I press the power button (while it's on) or do a shutdown from Windows, it shuts down as expected. Except that the fans then go to full speed! And furthermore the power button will not turn it on again; I have to pull the power cord out and put it back in, then push the power button, and it will come back on. If I press the "sleep" button on the keyboard (while it's on), it will sleep (although the fans will keep running)--but I can't get it to wake up! I have to pull the power cord again. I've tried a different power supply, with no change.

The eBay seller did warn me about this odd behaviour, but I assumed it was just a bad switch. However, the switch seems to work, because if you press it while the unit is on, Windows gets the message and shuts down. It seems to me to be a BIOS issue. I did compare the BIOS revision with the other identical machine that I have, and this is a later rev. Does anyone think that flashing the BIOS will cure the odd behaviour? Back-revving? Thanks in advance for any helpful ideas! - JR
April 27, 2009 10:54:19 PM

Flashed BIOS, no change...
April 27, 2009 11:07:31 PM

I have no clue what could be causing it. However, working with the assumption that some secular force is causing this odd behavior one can work to narrow down the problem. Try downloading a Ubuntu live CD and see if it does this under a Linux environment. If it does not, I would assume that there are some rogue drivers in your windows installation. Drivers that are conflicting with the S3 sleep state could be of issue; places to look are network cards and USB devices.

Conversely, there may be a hardware issue. Remove all unnecessary PCI cards and work from there. Taking the minimalist approach will allow you to pinpoint the source of the problem.

As in any 'scientific' experiment isolate your variables and remember that correlation is not causality.

Related resources
April 28, 2009 12:01:32 AM

OK, here's the update. First of all I should specify that the BIOS update was to the latest available version. After that didn't work I tried the minimalist approach: took the MB out of the case, laid it on the desk, and plugged in only a (different) P/S, kbd, and video. Turned it on with a screwdriver tip between the appropriate pins on the board. Still behaves the same way.

Let me give a more specific example of its behaviour. The computer is running, say sitting in BIOS setup. I touch the screwdriver to the pins, simulating pressing the power button. The CPU powers down, the CPU fan stops, but the P/S fan continues. (And if the HD were plugged in, it would continue spinning.) Then I touch the screwdriver to the pins again; that should power it back up. But instead, nothing happens. Then I pull the power cord, wait, and plug it in again. The fans all spin up, but the CPU doesn't power on (no action on the video monitor). When I touch the screwdriver to the pins again, it finally powers up.

Any more ideas? - JR
a c 144 ) Power supply
a c 156 V Motherboard
April 28, 2009 6:36:18 PM

Possibly Windows power management??
a b ) Power supply
a b V Motherboard
April 28, 2009 11:47:56 PM

Silly as it sound`s the jumper in the right place on the bios reset.
the jumper should always be sat on two pins, Ie two for short of bios
The other for normal operation.

!